Monkey and Banana——贪心和动态规划(类似LIS)结合水题

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food. 

 

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks. 

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n, 

representing the number of different blocks in the following data set. The maximum value for n is 30. 

Each of the next n lines contains three integers representing the values xi, yi and zi. 

Input is terminated by a value of zero (0) for n. 

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height". 

Sample Input

1

10 20 30

2

6 8 10

5 5 5

7

1 1 1

2 2 2

3 3 3

4 4 4

5 5 5

6 6 6

7 7 7

5

31 41 59

26 53 58

97 93 23

84 62 64

33 83 27

0

Sample Output

Case 1: maximum height = 40

Case 2: maximum height = 21

Case 3: maximum height = 28

Case 4: maximum height = 342

/*经典的一道dp题,思路挺简单,其实就是先贪心一下,然后再dp,这里dp和最长上升子序列问题(LIS)很相似,
贪心时按照底面积从大到小,注意,一组数据可以形成6个长方体,所以数据范围最大为30*6=180, 
然后dp时类似于LIS,状态:dp(i)以i为最上一层时的最大高度。状态转移方程: dp(i)=max{0 , dp(j) | j < i}+height(i);
*/




#include <bits/stdc++.h>
using namespace std;
struct block
{
     int x,y,z;
}block[185];
int dp[185];
bool  cmp( struct block a, struct block b)
{
   return a.x*a.y>b.x*b.y;
}
int main(){
    std::ios::sync_with_stdio(false);
    cin.tie(0);     //关闭同步流,加快cin/cout 速度
    int n,a,b,c;
    int cnt = 0;
    while(cin>>n && n)
    {
     cout<<"Case "<<++cnt<<": maximum height = ";
           for(int i = 1;i <= 6*n ; i++){
                   cin>>a>>b>>c; 
//这里表示长方体的6种情况。
                   block[i].x = a;
                   block[i].y = b;
                   block[i++].z = c;

                   block[i].x = a;
                   block[i].y = c;
                   block[i++].z = b;

                   block[i].x = b;
                   block[i].y = a;
                   block[i++].z = c;
                       
                   block[i].x = b;
                   block[i].y = c;
                   block[i++].z = a;
                        
                   block[i].x = c;
                   block[i].y = a;
                   block[i++].z = b;
                      
                   block[i].x = c;
                   block[i].y = b;
                   block[i].z = a;
                    
          }
        sort(block + 1,block + 6*n + 1,cmp);//贪心策略。
        for(int i = 1; i <= 6*n; i++){
              dp[i] = block[i].z; //以i为最上一层。
             for(int j = 1;j < i; j++){
                   if(block[i].x < block[j].x && block[i].y < block[j].y)//满足条件 上面的长和宽都要比下面的小。
                        if(dp[i] < block[i].z + dp[j])
                            dp[i] = block[i].z + dp[j];
                  }
            }
    int max_height = 0;
     for(int i = 1;i <= 6*n; i++)
               if(dp[i] > max_height)
                  max_height = dp[i];//更新最大高度
        cout<<max_height<<endl;
    }
    return 0;
}




 

  • 2
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值