Stones(HDU - 1896 )(优先队列)



Stones

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 2889    Accepted Submission(s): 1849


Problem Description
Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time. 
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first. 
 

Input
In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases. 
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.
 

Output
Just output one line for one test case, as described in the Description.
 

Sample Input
      
      
2 2 1 5 2 4 2 1 5 6 6
 

Sample Output
      
      
11 12
 

Author
Sempr|CrazyBird|hust07p43
 

Source
 

Recommend
lcy


题意理解:这道题我认为最重要的就是题意理解,只要理解了题意,会个·优先队列就可以过。
题意就是这个人扔石头,遇到奇数的石头扔,遇到偶数的不扔,遇到在同一地点的石头,优先扔大的石头,问你最后他扔得最远的石头,离出发点的距离。(PS:我做题的时候一直以为odd这个单词是 奇怪的意思,然后自己天马行空的理解奇怪的石头,然后一直过不了~~~~(>_<)~~~~)


#include<stdio.h>
#include<queue>
using namespace std;
struct s{
    int p;    //位置
    int str; //能扔的距离
    friend bool operator<(s a,s b)
    {
        if(a.p!=b.p)
            return a.p>b.p;     //如果位置不同,优先扔位置近的
        else
            return a.str>b.str;    //如果位置相同,优先扔石头大的,也就是他能扔得近的。
    }
};
int main()
{
    int T;
    scanf("%d",&T);
    int num=1;
    while(T--)
    {
        int n;
        scanf("%d",&n);
        priority_queue<s>q;
        int max_=0;
        for(int i=0;i<n;i++)
        {
            s temp;
            scanf("%d%d",&temp.p,&temp.str);
            if(temp.p>max_)
                max_=temp.p;
            q.push(temp);
        }
        while(!q.empty())
        {
            if(num%2==1)    //奇数扔
            {
                s temp=q.top();
                q.pop();
                temp.p=temp.p+temp.str;
                if(max_<temp.p)
                    max_=temp.p;    //记录最大值
                q.push(temp);
            }
            else    //偶数不扔
            {
                q.pop();
            }
            num++;
        }
        printf("%d\n",max_);
    }
}




 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值