1044. 火星数字(20)-PAT乙级

题目:

火星人是以13进制计数的:
地球人的0被火星人称为tret。
地球人数字1到12的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
火星人将进位以后的12个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。
例如地球人的数字“29”翻译成火星文就是“hel mar”;而火星文“elo nov”对应地球数字“115”。为了方便交流,请你编写程序实现地球和火星数字之间的互译。
输入格式:
输入第一行给出一个正整数N(<100),随后N行,每行给出一个[0, 169)区间内的数字 —— 或者是地球文,或者是火星文。
输出格式:
对应输入的每一行,在一行中输出翻译后的另一种语言的数字。
输入样例:
4
29
5
elo nov
tam
输出样例:
hel mar
may
115
13

解答:

#include<string>
#include<iostream>
using namespace std;
void trans1(string s)
{
    string a[13] = { "###", "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec" };
    string b[13] = { "###", "tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou" };
    int len = s.length();
    int t = 0;
    if (len == 1)
    {
        t = s[0] - '0';
    }
    else if (len == 2)
    {
        t = (s[0] - '0') * 10 + (s[1] - '0');
    }
    else
    {
        t = (s[0] - '0') * 100 + (s[1] - '0') * 10 + (s[2] - '0');
    }
    if (t <= 12)
    {
        cout << a[t] << endl;
    }
    else if (t % 13 == 0)
    {
        cout << b[t / 13] << endl;
    }
    else
    {
        cout << b[t / 13] << " " << a[t % 13] << endl;
    }
}
void trans2(string s)
{
    string a[13] = { "###", "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec" };
    string b[13] = { "###", "tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou" };
    int len = s.length();
    if (len == 3)
    {
        for (int i = 1;i < 12;i++)
        {
            if (s[0] == a[i][0] && s[1] == a[i][1] && s[2] == a[i][2])
                cout << i << endl;
            else if (s[0] == b[i][0] && s[1] == b[i][1] && s[2] == b[i][2])
                cout << i * 13 << endl;
        }
    }
    else
    {
        int t1 = 0;
        int t2 = 0;
        for (int j = 1; j <= 12; j++)
        {
            if (s[0] == b[j][0] && s[1] == b[j][1] && s[2] == b[j][2])
            {
                t1 = j;
            }
            if (s[4] == a[j][0] && s[5] == a[j][1] && s[6] == a[j][2])
            {
                t2 = j;
            }
        }
        cout << t1 * 13 + t2 << endl;
    }
}
int main()
{
    int N;
    cin >> N;
    getchar();//###
    for (int i = 0;i < N;i++)
    {
        string a;
        getline(cin, a);
        if (a.length() == 1 && a[0] == '0')
            cout << "tret" << endl;
        else
        {
            if (a[0] >= '0'&&a[0] <= '9')
                trans1(a);
            else
                trans2(a);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值