A. Point(类与构造)

A. Point(类与构造)

题目描述

下面是一个平面上的点的类定义,请在类外实现它的所有方法,并生成点测试它。

输入

测试数据的组数 t

第一组测试数据点p1的x坐标   第一组测试数据点p1的y坐标  第一组测试数据点p2的x坐标   第一组测试数据点p2的y坐标

..........

输出

输出p1到p2的距离

输入样例1 

2
1 2 3 4
-1 0.5 -2 5

输出样例1

Distance of Point(1.00,2.00) to Point(3.00,4.00) is 2.83
Distance of Point(-1.00,0.50) to Point(-2.00,5.00) is 4.61

 该题比较简单,主要考察类与构造函数的相关知识,主要注意格式输出

#define _CRT_SECURE_NO_WARNINGS
#include<iostream>
#include<algorithm>
#include<string>
#include<vector>
#include <iomanip>
#include<cmath>
#include<cstring>
#include<cctype>
#include<queue>
#include<set>
using namespace std;

class Point
{
private:
	double x, y;
public:
	Point();
	Point(double x_value, double y_value);
	double getX();
	double getY();
	void setX(double x_value);
	void setY(double y_value);
	double distanceToAnotherPoint(Point p);
};

Point::Point()
{
	x = 0;
	y = 0;
}

void Point::setX(double x_value)
{
	x = x_value;
}

void Point::setY(double y_value)
{
	y = y_value;
}

double Point::getX()
{
	return x;
}

double Point::getY()
{
	return y;
}

Point::Point(double x_value, double y_value)
{
	x = x_value;
	y = y_value;
}

double Point::distanceToAnotherPoint(Point p)
{
	return sqrt((p.x - this->x) * (p.x - this->x) + (p.y - this->y) * (p.y - this->y));
}
int main()
{
	int t;
	double x_v1, y_v1, x_v2, y_v2;
	cin >> t;
	Point p1,p2;
	while (t--)
	{
		cin >>x_v1 >> y_v1 >> x_v2 >> y_v2;
		Point p1(x_v1, y_v1);
		Point p2(x_v2, y_v2);
		cout << "Distance of Point(";
		cout << fixed << setprecision(2) << x_v1 << "," << y_v1 << ") to Point(" << x_v2 <<"," << y_v2 << ") is " << p1.distanceToAnotherPoint(p2) << endl;
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZZZWWWFFF_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值