【id:31】【20分】A. Point(类与构造)

题目描述

下面是一个平面上的点的类定义,请在类外实现它的所有方法,并生成点测试它。

输入

测试数据的组数 t

第一组测试数据点p1的x坐标   第一组测试数据点p1的y坐标  第一组测试数据点p2的x坐标   第一组测试数据点p2的y坐标

..........

输出

输出p1到p2的距离

在C++中,输出指定精度的参考代码如下:

#include <iostream>

#include <iomanip> //必须包含这个头文件

using namespace std;1

void main( )

{ double a =3.14;

  cout<<fixed<<setprecision(3)<<a<<endl;  //输出小数点后3位

}


输入样例

2
1 2 3 4
-1 0.5 -2 5


输出样例

Distance of Point(1.00,2.00) to Point(3.00,4.00) is 2.83
Distance of Point(-1.00,0.50) to Point(-2.00,5.00) is 4.61


#include<iostream>
#include<cmath>
#include<iomanip>
using namespace std;

class Point
{
private:
	double x, y;
public:
	//初始化对象 xy的值
	Point();
	Point(double x_value, double y_value);
	//获取x y的值
	double getX();
	double getY();
	//求两点间距离
	double distanceToAnotherPoint(Point r);
};

//初始化对象 xy的值
Point::Point() {
	x = 0, y = 0;
}

Point::Point(double x_value, double y_value) {
	//因为是私有 所以 x 和this->x 都是指类里面私有的x   最好写this-> 清晰一点
	x = x_value;
	this->y = y_value;
}

//获取x y的值
double Point::getX() {
	return x;
}

double Point::getY() {
	return this->y;
}


//求两点间距离
double Point::distanceToAnotherPoint(Point r) {
	//勾股定理
	//this->x 指p1的x           r.getX()指 p2的x  
	return sqrt(pow(this->x - r.getX(), 2) + pow(this->y - r.getY(), 2));
	//(p1.x-p2.x)的平方+(p1.y-p2.y)的平方   再开根号
}
int main()
{
	int t;
	double x1, y1, x2, y2;
	cin >> t;
	while (t--) {
		cin >> x1 >> y1 >> x2 >> y2;
		//初始化对象 xy的值
		Point p1(x1, y1);
		Point p2(x2, y2);
		//求距离
		double distance = p1.distanceToAnotherPoint(p2);
		// fixed << setprecision(2) <<   保留两位小数字
		cout << fixed << setprecision(2) << "Distance of Point(" << p1.getX() << "," << p1.getY()
			<< ") to Point(" << p2.getX() << "," << p2.getY() << ") is " << distance << endl;
	}
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值