括号配对问题
时间限制:
3000 ms | 内存限制:
65535 KB
难度:
3
-
描述
-
现在,有一行括号序列,请你检查这行括号是否配对。
-
输入
- 第一行输入一个数N(0<N<=100),表示有N组测试数据。后面的N行输入多组输入数据,每组输入数据都是一个字符串S(S的长度小于10000,且S不是空串),测试数据组数少于5组。数据保证S中只含有"[","]","(",")"四种字符 输出
- 每组输入数据的输出占一行,如果该字符串中所含的括号是配对的,则输出Yes,如果不配对则输出No 样例输入
-
3 [(]) (]) ([[]()])
样例输出
-
No No Yes
</pre><pre name="code" class="html">
#include<stdio.h>
#include<string.h>
#include<stack>
using namespace std;
int main(){
int n;
char str[10005];
scanf("%d",&n);
while(n--){
stack<char> s;
scanf("%s",str);
// 括号配对问题
for(int i=0;i<strlen(str);i++){
if(s.empty()) s.push(str[i]); //栈空,入栈
else{
if(s.top()+1==str[i]||s.top()+2==str[i])//"(" 40、")" 41 差 1,"[" 91 、"]" 93 差 2
s.pop(); //top()取队首元素,但不删除 pop()出栈
else s.push(str[i]); // push()入栈
}
}
//Returns true if the stack is empty.
if(s.empty()) printf("Yes\n");
else printf("No\n");
}
return 0;
}