【贪心】poj-1852 Ants (TZ)

题目描述了一群蚂蚁在杆上行走,遇到尽头会掉下,相遇则会回头。求最早和最晚所有蚂蚁掉下杆的时间。解题关键在于理解蚂蚁相遇相当于穿过,可以用贪心策略解决:最早时间取所有蚂蚁到杆子最短距离的最大值,最晚时间取所有蚂蚁到杆子最长距离的最大值。
摘要由CSDN通过智能技术生成

Ants

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 25933 Accepted: 10181

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

【题解】:

其实遇到蚂蚁相遇之后,两只蚂蚁折返回头,这不就是相当于两只蚂蚁穿过去吗?

其实只要你想到这里,这个题目就可以贪心写出来了,

最小时间,也就是全部蚂蚁到竿子最短距离,然后取最大值。

最大时间,也就是全部蚂蚁到竿子最长距离,然后取最大值。


#include<cstdio>
#include<algorithm>
using namespace std;
int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        int L,n;
        scanf("%d%d",&L,&n);
        int maxz=-1,minz=0,x;
        for(int i=1;i<=n;i++){
            scanf("%d",&x);
            maxz=max(max(x,L-x),maxz);
            minz=max(min(x,L-x),minz);
        }
        printf("%d %d\n",minz,maxz);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值