实验3_3_确定成绩等级 (100 point(s))

将百分制成绩score按下列原则划分其等级:

score≥90等级为A;

80 ≤score<90,等级为B;

70≤score<80,等级为C;

60≤score<70,等级为D;

score<60,等级为E。

输入格式:

只有一个整数,代表成绩score。测试用例保证所有整数可以用int存储。

输出格式:

只有一行,当成绩小于0或大于100时为"The score is out of range!"(不包括引号),否则为输入的学生成绩对应的等级。

输入样例:

89

输出样例:

B
#include<stdio.h>
int main(){
	int score;
	scanf("%d",&score);
	if((score>=90)&&(score<=100))printf("A");
	else if((score>=80)&&(score<90))printf("B");
	else if((score>=70)&&(score<80))printf("C");
	else if((score>=60)&&(score<70))printf("D");
	else if((score<60)&&(score>=0))printf("E");
	else printf("The score is out of range!");
	
   	return 0; 

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值