CSU-ACM2017暑期训练1-Debug与STL hdu1896-Stones

题目链接:stones

题目:

Stones

Time Limit: 5000/3000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 2980 Accepted Submission(s): 1918


Problem Description
Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time.
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.

Input
In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases.
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.

Output
Just output one line for one test case, as described in the Description.

Sample Input
  
  
2 2 1 5 2 4 2 1 5 6 6

Sample Output
  
  
11 12

题目大意:小明沿着一条路走,每遇到一个石头,如果是第奇数次遇到的,就将他往前扔(每个石头的两个属性:位置和能扔多远)。否则忽略它。如果一个位置有多个石头,优先考虑能扔的距离最小的石头。求最后没有石头可以扔时,距离起点最远的那个石头有多远。

思路:由于优先考虑能扔距离最小的石头,于是用优先队列。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;

struct Position
{
    int pos;
    int dis;
    friend bool operator < (Position a,Position b)
    {
        if(a.pos!=b.pos)
            return a.pos>b.pos;
        else
            return a.dis>b.dis;
    }
};

priority_queue<Position>p;

int main()
{
    int t,n;
    int step,max_pos;
    Position x,a;
    scanf("%d",&t);
    while(t--)
    {
        while(!p.empty())
            p.pop();
        max_pos=-1;
        step=0;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&x.pos,&x.dis);
            p.push(x);
        }
        x.dis=x.pos=-1;
        while(!p.empty())
        {
            step++;
            if(step%2)
            {
                x=p.top();
                p.pop();
                x.pos+=x.dis;
                max_pos=max(max_pos,x.pos);
                p.push(x);
            }
            else
            {
                x=p.top();
                max_pos=max(max_pos,x.pos);
                p.pop();
            }
        }
        printf("%d\n",max_pos);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值