HDU - 2767 Proving Equivalences(tarjan缩点)

题目

Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

  1. A is invertible.
  2. Ax = b has exactly one solution for every n × 1 matrix b.
  3. Ax = b is consistent for every n × 1 matrix b.
  4. Ax = 0 has only the trivial solution x = 0.

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?

Input

On the first line one positive number: the number of testcases, at most 100. After that per testcase:

  • One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
  • m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.

Output

Per testcase:

  • One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.

Sample Input

2
4 0
3 2
1 2
1 3

Sample Output

4
2

题意:

给一个有向图,问最少添加几条边使得有向图成为一个强连通图。

思路:

Tarjan入门经典题,用tarjan缩点,然后就变成一个DAG了。
我们要考虑的问题是让它变成强连通,让DAG变成强连通就是把尾和头连起来,也就是入度和出度为0的点
统计DAG入度和出度,然后计算头尾,最大的那个就是所求

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<vector>
#include<stack>
#include<bitset>
#include<cstdlib>
#include<cmath>
#include<set>
#include<list>
#include<deque>
#include<map>
#include<queue>
using namespace std;
typedef long long ll;
const double PI = acos(-1.0);
const double eps = 1e-6;
const int INF = 1000000000;
const int maxn = 56789;
int T,n,m,tot,time,scc;
int cnt_in,cnt_out;
int head[maxn],dfn[maxn],low[maxn],belong[maxn];
int in[maxn],out[maxn];
stack<int>st;

struct DEGE
{
    int v;
    int next;
}e[maxn];

void init()
{
    cnt_in=cnt_out=time=scc=tot=0;
    memset(head,-1,sizeof(head));
    memset(dfn,0,sizeof(dfn));
    memset(low,0,sizeof(low));
    memset(in,0,sizeof(in));
    memset(out,0,sizeof(out));
    memset(belong,0,sizeof(belong));
    while(!st.empty())
        st.pop();
}

void add_edge(int u,int v)
{
    tot++;
    e[tot].v=v;
    e[tot].next=head[u];
    head[u]=tot;
}

void dfs(int u)
{
    dfn[u]=low[u]=++time;
    st.push(u);
    for(int i=head[u];i!=-1;i=e[i].next)
    {
        int v=e[i].v;
        if(!dfn[v])
        {
            dfs(v);
            low[u]=min(low[u],low[v]);
        }
        else if(!belong[v])
        {
            low[u]=min(low[u],dfn[v]);
        }
    }
    if(low[u]==dfn[u])
    {
        scc++;
        while(st.top()!=u)
        {
            int x=st.top();
            st.pop();
            belong[x]=scc;
        }
        belong[u]=scc;
        st.pop();
    }
}

void Get_point()
{
    for(int i=1;i<=n;i++)
    {
        for(int j=head[i];j!=-1;j=e[j].next)
        {
            int v=e[j].v;
            if(belong[i]!=belong[v])
            {
                out[belong[i]]++;
                in[belong[v]]++;
            }
        }
    }
}

void Find_scc()
{
    for(int i=1;i<=n;i++)
    {
        if(!dfn[i])
        {
            dfs(i);
        }
    }
}

int main()
{
    scanf("%d",&T);
    while(T--)
    {
        init();
        scanf("%d%d",&n,&m);
        for(int i=0;i<m;i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            add_edge(u,v);
        }
        Find_scc();
        Get_point();
        for(int i=1;i<=scc;i++)
        {
            if(in[i]==0)
                cnt_in++;
            if(out[i]==0)
                cnt_out++;
        }
        if(scc==1)
            printf("0\n");
        else
            printf("%d\n",max(cnt_in,cnt_out));
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值