HDU-2767 Proving Equivalences(tarjan缩点 SCC题模板)

                                 Proving Equivalences   HDU-2767

Consider the following exercise, found in a generic linear algebra textbook.  

Let A be an n × n matrix. Prove that the following statements are equivalent:  

1. A is invertible.  
2. Ax = b has exactly one solution for every n × 1 matrix b.  
3. Ax = b is consistent for every n × 1 matrix b.  
4. Ax = 0 has only the trivial solution x = 0.  

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.  

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!  

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?
InputOn the first line one positive number: the number of testcases, at most 100. After that per testcase:  

* One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.  
* m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.OutputPer testcase:  

* One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.Sample Input
2
4 0
3 2
1 2
1 3
Sample Output
4
2

题目大概意思:数学上有很多定义,给出m条证明,让n个定义能够互通(加多少条边能够构成一个连通图

/* HDU 2767 */
/* 2018 2-22*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<ctime>
#include<cstdlib>
#include<cmath>
#include<string>
#include<queue>
#include<vector>
#include<stack>
#include<list>
#include<set>
#define manx maxn
#define mem(a,b) memset(a,b,sizeof(a))
const int maxn = 20000 +10;
using namespace std;
int Lext[maxn],Next[maxn*100],To[maxn*100],dfn[maxn],low[maxn],vis[maxn],stc[maxn];
int in[maxn],out[maxn],scc[maxn];
int top,scc_cnt,cnt,times,n,m;
void init()
{
    mem(Lext,0);
    mem(Next,0);
    mem(To,0);
    mem(dfn,0);
    mem(low,0);
    mem(vis,0);
    mem(stc,0);
    mem(in,0);
    mem(out,0);
    mem(stc,0);
    mem(scc,0);
    scc_cnt = cnt= times = top =0;
}
void add(int u,int v)
{
    Next[++cnt]=Lext[u];
    Lext[u]=cnt;
    To[cnt]=v;
}
int dfs(int u)
{
    dfn[u]=low[u]=++times;//时间截记录
    stc[++top]=u;//模拟栈 入栈
    vis[u]=1;// 记忆 
    for(int i=Lext[u]; i; i=Next[i])
    {
        int v=To[i];
        if(!dfn[v])
        {
            dfs(v);
            low[u]=min(low[u],low[v]);
        }
        else if (vis[v])//v是u祖先
            low[u]=min(low[u],dfn[v]);
    }
    if(low[u]==dfn[u])
    {
        scc_cnt++;
        while(true)
        {
            int x=stc[top--];
            scc[x]=scc_cnt;
            vis[x]=0;
            if(x==u) break;
        }
    }
}
void tarjan()
{
    for(int i=1; i<=n; i++)
        if(!dfn[i]) dfs(i);
    for(int i=1; i<=n; i++)
        for(int j=Lext[i]; j; j=Next[j])
        {
            int v=To[j];
            if(scc[v]!=scc[i])//连接的两点不在同一连通图里
            {
                in[scc[v]]++;   // i -> v   i点为出度  v点为入度
                out[scc[i]]++;
            }
        }
    int a=0,b=0;
    for(int i=1; i<=scc_cnt; i++)//记录出度入度为0的个数  
    {
        if(in[i]==0) a++;
        if(out[i]==0) b++;
    }
    if(scc_cnt<=1) printf("0\n");
    else printf("%d\n",max(a,b));
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int u,v;
        init();
        scanf("%d %d",&n,&m);
        for(int i=1; i<=m; i++)
        {
            scanf("%d %d",&u,&v);
            add(u,v);
        }
        tarjan();
    }
}

微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值