POJ-2260 Error Correction 模拟

Error Correction

A boolean matrix has the parity property when each row and each column has an even sum, i.e. contains an even number of bits which are set. Here’s a 4 x 4 matrix which has the parity property:
1 0 1 0

0 0 0 0

1 1 1 1

0 1 0 1

The sums of the rows are 2, 0, 4 and 2. The sums of the columns are 2, 2, 2 and 2.
Your job is to write a program that reads in a matrix and checks if it has the parity property. If not, your program should check if the parity property can be established by changing only one bit. If this is not possible either, the matrix should be classified as corrupt.

Input

The input will contain one or more test cases. The first line of each test case contains one integer n (n<100), representing the size of the matrix. On the next n lines, there will be n integers per line. No other integers than 0 and 1 will occur in the matrix. Input will be terminated by a value of 0 for n.

Output

For each matrix in the input file, print one line. If the matrix already has the parity property, print “OK”. If the parity property can be established by changing one bit, print “Change bit (i,j)” where i is the row and j the column of the bit to be changed. Otherwise, print “Corrupt”.

Sample Input

4
1 0 1 0
0 0 0 0
1 1 1 1
0 1 0 1
4
1 0 1 0
0 0 1 0
1 1 1 1
0 1 0 1
4
1 0 1 0
0 1 1 0
1 1 1 1
0 1 0 1
0

Sample Output

OK
Change bit (2,3)
Corrupt

这个题是模拟类型的题,所谓模拟,就是编写程序实现题目要求的行为。不过因为要求多变(当然比产品经理还是好多了),所以难度也不一而定,比如这个题目就是简单的那种。
这个题目直接想的话就先看看O不OK,不OK一个个顺着来呗,但是这样的话先不说超时,肯定自己写着都觉得麻烦。
所以换个思路咯:直接申请两个数组一个用来存放各行1的个数,一个存放各列1的个数,最后统计1个数为奇数的列数和行数,如果都等于0就OK,都为1就输出Change bit(行+1,列+1)(虽然程序员是从0开始数的可是答案不是哇)

代码

#include <cstdio>
#include <iostream>
#include <memory.h>
using namespace std;
int col[101],row[101],n1,n2,x1,x2,n;
//int matrix[101][101];发博客的时候突然反应过来根本不需要这个东西了
void check(void);
int main()
{
    cin>>n;
    int temp;
    while(n){
        n1=n2=0;
        memset(col,0,sizeof(col));
        memset(row,0,sizeof(row));
        for(int i=0;i<n;++i){
            for(int j=0;j<n;++j){
                scanf("%d",&temp);
                //matrix[i][j]=temp;
                if(temp){
                    col[i]++;
                    row[j]++;
                }
            }
        }
        check();
        cin>>n;
    }
}
void check()
{
    for(int i=0;i<n;++i){
        if(col[i]%2){
            ++n1;
            x1=i;
        }
        if(row[i]%2){
            ++n2;
            x2=i;
        }
        if(n1>1||n2>1){
            cout<<"Corrupt"<<endl;
            return;
        }
    }
    if(n1&&n2){
        cout<<"Change bit ("<<x1+1<<','<<x2+1<<')'<<endl;
        return;
    }else if(!n1&&!n2){
        cout<<"OK"<<endl;
        return;
    }else{
        cout<<"Corrupt"<<endl;
        return;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值