Buy Tickets (线段树)

Buy Tickets

Time Limit : 8000/4000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 48   Accepted Submission(s) : 23
Problem Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

 

Input
<p>There will be several test cases in the input. Each test case consists of <i>N</i> + 1 lines where <i>N</i> (1 ≤ <i>N</i> ≤ 200,000) is given in the first line of the test case. The next <i>N</i> lines contain the pairs of values <i>Pos<sub>i</sub></i> and <i>Val<sub>i</sub></i> in the increasing order of <i>i</i> (1 ≤ <i>i</i> ≤ <i>N</i>). For each <i>i</i>, the ranges and meanings of <i>Pos<sub>i</sub></i> and <i>Val<sub>i</sub></i> are as follows:</p><ul><li><i>Pos<sub>i</sub></i> ∈ [0, <i>i</i> − 1] — The <i>i</i>-th person came to the queue and stood right behind the <i>Pos<sub>i</sub></i>-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.</li><li><i>Val<sub>i</sub></i> ∈ [0, 32767] — The <i>i</i>-th person was assigned the value <i>Val<sub>i</sub></i>.</li></ul><p>There no blank lines between test cases. Proceed to the end of input.</p>
 

Output
<p>For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.</p>
 

Sample Input
  
  
4 0 77 1 51 1 33 2 69 4 0 20523 1 19243 1 3890 0 31492
 

Sample Output
  
  
77 33 69 51 31492 20523 3890 19243
 

题目大概:

给出n个数并且动态的给出它此时所在位置。求最后这个数列的顺序。

思路:

线段树单点更新,先把数据离线一下,然后倒着放入线段树里,放里面填就行。

代码:


#include <iostream>
#include <cstdio>

#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1

using namespace std;
int sum[222222<<2];
int ans[222222<<2];
void push(int rt)
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];

}
void build(int l,int r,int rt)
{   sum[rt]=r-l+1;
    if(l==r)
    {

        return;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    push(rt);

}

void update(int l,int r,int rt,int k,int v)
{
    if(l==r)
    {
        ans[rt]=k;
        sum[rt]--;
        return;
    }
    int m=(l+r)>>1;
    if(v<=sum[rt<<1])
    {
        update(lson,k,v);
    }
    else
    {
        update(rson,k,v-sum[rt<<1]);
    }
    push(rt);
}

void pri(int l,int r,int rt)
{
    if(l==r)
    {
        printf("%d ",ans[rt]);
        return;
    }
    int m=(l+r)>>1;
    pri(lson);
    pri(rson);
}
int main()
{
    int n;
    int kk[222222];
    int vv[222222];
    while(~scanf("%d",&n))
    {


    for(int i=1;i<=n;i++)
    {
        scanf("%d%d",&vv[i],&kk[i]);
    }
    build(1,n,1);
    for(int i=n;i>0;i--)
    {
        update(1,n,1,kk[i],vv[i]+1);
    }
    pri(1,n,1);
    printf("\n");
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值