Buy Tickets (线段树----容易理解的方法)

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input
4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492
Sample Output
77 33 69 51
31492 20523 3890 19243
Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

昂 , 这题看了好久 , 然后搜题解去了~~~然后题解还看了好久。。。。。。。。。真是菜到想吃小饼干。。。。。

题意:

排队买票时候插队。 
给出一些数对,分别代表某个人的想要插入的位置Pos_i和他的Val_i,求出最后的队列的val顺序。

在第pos[i]处插入一个元素,则第pos[i]处后的所有元素都将向后移动一位,看起来是平均每次插入需要n次操作。 
但是我们可以看出,对每次插入来说,本次插入结束后本次所插入的元素位置一定会是pos[i]+1,那么与其先插入可能会需要向后移动的元素,不如从最后一个被插入的元素开始向一个[0,m]的空区间插入元素,这样每一次插入都不会对已经记录的状态产生影响。 

解释看代码:

#include <stdio.h>
#include <iostream>
using namespace std;

#define lson l , m , rt << 1
#define rson m+1  , r , rt<<1|1

const int maxn = 200005;
int val[maxn] , pos[maxn] , ans[maxn] , sum[maxn << 2];
 //(价值)   ( 位置)    (输出答案) (节点更新) 
void PushUp(int rt)//----更新每个操作结束后,该节点还有多少个可用的空间 
{
	sum[rt] = sum[rt<<1] +sum[rt<<1|1];
 } 
 void Build(int l , int r , int rt)
 {
 	
 	if(l == r)
 	{
	 	sum[rt] = 1;//当达到叶子节点时,使其值为1,表示该地有一个空位可用 
 		return ;
	 }
	 int m =(l+r)>>1;
	 Build(lson);
	 Build(rson);
	 PushUp(rt);
 }
 void add(int z , int p , int l , int r , int rt)
 {//z表示输入的位置,p是最后的值 
 	if(l==r)
 	{
 		ans[l] = p; 
 		sum[rt] = 0;//表示这个位置用掉了 
 		return;
	 }
	 int m = (l+r) >> 1;
	 if(z < sum[rt<<1]) add(z , p , lson);// 空位满足条件的话 , 就往左走 
	 else add(z-sum[rt<<1] , p , rson);//注意在右边的话 要减去左边的空位数 
	 PushUp(rt);
 } 
 int main()
 {
 	int n;
 	while(~scanf("%d" , &n))
 	{
 		Build(1 , n , 1);
 		for(int i = 0 ; i < n ; i++)
 		{
 			scanf("%d%d" , &pos[i] ,  &val[i]);
		 }
		 for(int i = n-1 ; i >= 0; i--)
		 {
		 	add(pos[i] , val[i] , 1 , n , 1);
		 }
		 for(int i = 1 ; i <= n ; i++)
		 {//注意这里输出要往后加一位 , 因为每输入的pos[i] 插入在pos[i+1]上 
		 	printf("%d " , ans[i]);
		 }
		 printf("\n");
	 }
 	return 0;
 }





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值