H - Bomb

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
Output
For each test case, output an integer indicating the final points of the power.
Sample Input
3
1
50
500
Sample Output
0
1
15


        
  

题目大概:

找出1到n之间的含有连续的49的数的个数。

思路:

基础数位dp。

代码:


#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int a[30];
long long dp[30][20][15];

long long sove(int pos,int qian,int bb,int limit)
{
    if(pos==-1)return bb;
    if(!limit&&dp[pos][qian][bb]!=-1)return dp[pos][qian][bb];
    long long sum=0;
    int end=limit?a[pos]:9;
    for(int i=0;i<=end;i++)
    {
        if(qian==4&&i==9)sum+=sove(pos-1,i,1,limit&&(i==a[pos]));
        else sum+=sove(pos-1,i,bb,limit&&(i==a[pos]));
    }
    if(!limit)dp[pos][qian][bb]=sum;
    return sum;
}

long long go(long long x)
{
    int pos=0;
    while(x)
    {
        a[pos++]=x%10;
        x/=10;
    }
    return sove(pos-1,0,0,1);
}
int main()
{
    int n;
    cin>>n;
    while(n--)
    {   long long m;
        memset(dp,-1,sizeof(dp));
        scanf("%I64d",&m);
        printf("%I64d\n",go(m));
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值