Bomb (数位DP)

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
Output
For each test case, output an integer indicating the final points of the power.
Sample Input
3
1
50
500
Sample Output
0
1
15


        
  
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499",
so the answer is 15. 

题目大意:

求1到n直间含有49的个数

思路代码(超时):

通过跑了一遍暴力发现每1000个数里有20个符合题意(从1 开始),所以用了找规律的方法,结果T了。。。。。

如果数据比较水应该是可以用的

#include<stdio.h>
#include<string.h>
using namespace std;
typedef long long ll;
int Is(ll x){
	int flag=0;
	while(x){
		if(x%10==9){
			flag=1;
			x/=10;
		}
		if(x%10==4&&flag) return 1;
		if(x%10==9) flag=1;
		else flag=0;
		x/=10;
	}
	return 0;
}
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
    	ll n;
    	scanf("%d",&n);
    	ll cnt=0,i;
    	cnt=n/1000*20;
    	for(i=n/1000*1000;i<=n;i++)
    	  cnt+=Is(i);
    	printf("%lld\n",cnt);
	}
	return 0;
} 

数位DP思路:(正解)

#include<stdio.h>
#include<string.h>
using namespace std;
typedef long long ll;
int a[65];
ll dp[65][3];
//dp[pos][have];
//pos : 当前数位 
//have: 0:前一位不是4 :1:前一位不是4 2:出现过49 
ll Dfs(int pos,int have,bool limit){
	if(pos==-1) return have==2;
	if(!limit&&dp[pos][have]!=-1) return dp[pos][have];
	int up=limit?a[pos]:9;
	ll cnt=0,i;
	int havex;
	for(i=0;i<=up;i++){
		havex=have;
		if(have==0&&i==4) havex=1;
		if(have==1&&i!=4) havex=0;
		if(have==1&&i==9) havex=2;
		cnt+=Dfs(pos-1,havex,limit&&i==a[pos]);
	}
	if(!limit) dp[pos][have]=cnt;
	return cnt;
}
ll solve(ll x){
	int pos=0;
	while(x){
		a[pos++]=x%10;
		x/=10;
	}
	return Dfs(pos-1,0,true);
}
int main(){
	int T;
	scanf("%d",&T);
	memset(dp,-1,sizeof(dp));
	while(T--){
		ll n;
		scanf("%lld",&n);
		printf("%lld\n",solve(n));
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值