LightOJ - 1369 (推公式)

The problem you need to solve here is pretty simple. You are give a function f(A, n), where A is an array of integers and nis the number of elements in the array. f(A, n) is defined as follows:

long long f( int A[]int n ) { // n = size of A

    long long sum = 0;

    for( int i = 0; i < n; i++ )

        for( int j = i + 1; j < n; j++ )

            sum += A[i] - A[j];

    return sum;

}

Given the array A and an integer n, and some queries of the form:

1)      0 x v (0 ≤ x < n, 0 ≤ v ≤ 106), meaning that you have to change the value of A[x] to v.

2)      1, meaning that you have to find f as described above.

Input

Input starts with an integer T (≤ 5), denoting the number of test cases.

Each case starts with a line containing two integers: n and q (1 ≤ n, q ≤ 105). The next line contains n space separated integers between 0 and 106 denoting the array A as described above.

Each of the next q lines contains one query as described above.

Output

For each case, print the case number in a single line first. Then for each query-type "1" print one single line containing the value of f(A, n).

Sample Input

1

3 5

1 2 3

1

0 0 3

1

0 2 1

1

Sample Output

Case 1:

-4

0

4

 

题目大意:

给出n个数。给出一个f函数。

给出2种操作。

一,0  x   v   把x坐标的值换成v。

二,1输出f函数

思路:

当值发生变化时,推出O(1)计算f函数值的公式。

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <vector>
#include <cmath>
#include <algorithm>
#include <map>
#include <queue>
using namespace std;
#define ll long long
const int maxn = 1e5 + 100;
const int mod = 1e9 + 7;
ll a[maxn];
ll sum;
int n, m;
void f()
{
	for (int j = n;j >= 1;j--)
	{
		if (j != 1)sum -= (long long)a[j] * (j - 1);
		if (j != n)sum += (long long)a[j] * (n - j);
	}

}
int main()
{
	int t;
	scanf("%d", &t);
	int T = 1;
	while (t--)
	{

		scanf("%d%d", &n, &m);
		sum = 0;
		for (int i = 1;i <= n;i++)
		{
			scanf("%lld", &a[i]);
		}

		f();
		printf("Case %d:\n", T++);
		for (int i = 1;i <= m;i++)
		{
			int flag;
			scanf("%d", &flag);
			if (flag == 0)
			{
				int x;
				ll v;
				scanf("%d%lld", &x, &v);
				x++;
				sum = sum + (long long)(n - 2 * x + 1)*(v - a[x]);
				a[x] = v;
			}
			else
			{
				printf("%lld\n", sum);
			}
		}

	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值