LightOJ 1369 - Answering Queries (预处理)

1369 - Answering Queries



Description

The problem you need to solve here is pretty simple. You are give a function f(A, n), where A is an array of integers and n is the number of elements in the array. f(A, n) is defined as follows:

long long f( int A[]int n ) { // n = size of A

    long long sum = 0;

    for( int= 0; i < n; i++ )

        for( int= i + 1; j < n; j++ )

            sum += A[i] - A[j];

    return sum;

}

Given the array A and an integer n, and some queries of the form:

1)      0 x v (0 ≤ x < n, 0 ≤ v ≤ 106), meaning that you have to change the value of A[x] to v.

2)      1, meaning that you have to find f as described above.

Input

Input starts with an integer T (≤ 5), denoting the number of test cases.

Each case starts with a line containing two integers: n and q (1 ≤ n, q ≤ 105). The next line contains n space separated integers between 0 and 106 denoting the array A as described above.

Each of the next q lines contains one query as described above.

Output

For each case, print the case number in a single line first. Then for each query-type "1" print one single line containing the value of f(A, n).

Sample Input

1

3 5

1 2 3

1

0 0 3

1

0 2 1

1

Sample Output

Case 1:

-4

0

4

题意:不解释了,应该都能看懂


思路:预处理求出没有变化之前的ans值,然后当改变的时候:用d来表示改变量,数会有减别的数和被别的数减的情况,当减别的数时,ans变化了d*c,当被减时,ans变化了d*(n-c-1)  (ps:因为数组下边是从0开始的,所以-1),因为前面已经预处理了初始和,所以后面之需要判断ans的总变化就行了,最后改一下被修改的那个值。


ac代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define MAXN 444440
#define MOD 1000000007  
#define LL long long  
using namespace std;
LL a[MAXN];
int main()
{
	LL t,i,n,m;
	int cas=0;
	scanf("%lld",&t);
	while(t--)
	{
		LL sum=0;
		scanf("%lld%lld",&n,&m);
		for(i=0;i<n;i++)
		{
			scanf("%lld",&a[i]);
			sum+=a[i];
	    }
		LL ans=0;
		for(i=0;i<n;i++)
		{
			ans+=((n-i-1)*a[i]-(sum-a[i]));
			sum-=a[i];
		}
		//printf("%lld\n",ans);
		printf("Case %d:\n",++cas);
		while(m--)
		{
			LL ch;
			scanf("%d",&ch);
			if(ch==1)
			{
				printf("%lld\n",ans);
			}
			else if(ch==0)
			{
				LL c,b;
				scanf("%lld%lld",&c,&b);
				LL d=a[c]-b;
				a[c]=b;
				ans+=(d*c-d*(n-c-1));
			}
		}
	}
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值