数据结构实验之二叉树五:层序遍历

数据结构实验之二叉树五:层序遍历

Time Limit: 1000MS Memory limit: 65536K

题目描述

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。

输入

  输入数据有多行,第一行是一个整数t (t<1000),代表有t行测试数据。每行是 一个长度小于50个字符的字符串。

输出

  输出二叉树的层次遍历序列。

示例输入

2
abd,,eg,,,cf,,,
xnl,,i,,u,,

示例输出

abcdefg
xnuli

提示

 

来源

 xam

示例程序

 

#include<stdio.h>
#include<stdlib.h>

#define TRUE 1
#define FALSE 0
#define OK 1
#define ERROR 0
#define OVERFLOW -1
#define MAXQSIZE 100
typedef int Status;

typedef char TElemType;
 TElemType ch[51];
 Status i=-1;
typedef struct BiTNode
{
    TElemType data;
    struct BiTNode *lchild,*rchild;
} BiTNode,*BiTree;

typedef BiTree QElemType;

typedef struct
{
    QElemType *base;
    int front;
    int rear;
} SqQueue;

Status InitQueue(SqQueue *Q)
{
    (*Q).base=(QElemType *)malloc(MAXQSIZE*sizeof(QElemType));
    if(!(*Q).base)
        exit(OVERFLOW);
    (*Q).front=(*Q).rear=0;
    return OK;
}

Status QueueEmpty(SqQueue Q)
{
    if(Q.front==Q.rear)
        return TRUE;
    else
        return FALSE;
}

Status EnQueue(SqQueue *Q,QElemType e)
{
    if(((*Q).rear+1)%MAXQSIZE==(*Q).front)
        return ERROR;
    (*Q).base[(*Q).rear]=e;
    (*Q).rear=((*Q).rear+1)%MAXQSIZE;
    return OK;
}

Status DeQueue(SqQueue *Q,QElemType *e)
{
    if((*Q).front==(*Q).rear)
        return ERROR;
    *e=(*Q).base[(*Q).front];
    (*Q).front=((*Q).front+1)%MAXQSIZE;
    return OK;
}

void CreateBiTree(BiTree *T)
{
    i++;
    if(ch[i]==',')
        *T=NULL;
    else
    {
        *T=(BiTree)malloc(sizeof(BiTNode));
        if(!*T)
            exit(OVERFLOW);
        (*T)->data=ch[i];
        CreateBiTree(&(*T)->lchild);
        CreateBiTree(&(*T)->rchild);
    }
}

Status visitT(TElemType e)
{
    printf("%c",e);
    return OK;
}

void LevelOrderTraverse(BiTree T,Status(*Visit)(TElemType))
{
    SqQueue Q;
    BiTree P;
    InitQueue(&Q);
    if(T) EnQueue(&Q,T);
    while(Q.front != Q.rear)
    {
        DeQueue(&Q,&P);
        Visit(P->data );
        if (P->lchild) EnQueue(&Q, P->lchild);
        if (P->rchild) EnQueue(&Q, P->rchild);
    }

    return ;
}

int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%s",ch);
        BiTree T;
        i=-1;
        CreateBiTree(&T);
        LevelOrderTraverse(T,visitT);
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
好的,下面是层序遍历二叉树的实验报告: 一、实验目的 通过本实验,了解二叉树层序遍历算法,掌握用队列实现二叉树层序遍历的方法。 二、实验内容 1. 二叉树层序遍历算法 层序遍历是按照从上到下、从左到右的顺序遍历二叉树的每个结点。具体实现方法是:从根结点开始,将根结点入队,然后依次取出队首结点,将其左右子结点入队,直到队列为空。 2. 用队列实现二叉树层序遍历的方法 为了实现层序遍历,需要用到队列的数据结构。具体实现方法是:将根结点入队,然后依次取出队首结点,将其左右子结点入队,直到队列为空。 三、实验步骤 1. 定义二叉树结构体 ``` struct TreeNode { int val; struct TreeNode *left; struct TreeNode *right; }; ``` 2. 定义队列结构体 ``` struct QueueNode { struct TreeNode *node; struct QueueNode *next; }; ``` 3. 实现队列的入队和出队操作 ``` void enqueue(struct QueueNode **rear, struct TreeNode *node) { struct QueueNode *newNode = (struct QueueNode*)malloc(sizeof(struct QueueNode)); newNode->node = node; newNode->next = NULL; if (*rear == NULL) { *rear = newNode; } else { (*rear)->next = newNode; *rear = newNode; } } struct TreeNode* dequeue(struct QueueNode **front) { if (*front == NULL) { return NULL; } else { struct TreeNode *node = (*front)->node; struct QueueNode *temp = *front; *front = (*front)->next; free(temp); return node; } } ``` 4. 实现二叉树层序遍历函数 ``` void levelOrder(struct TreeNode* root) { if (root == NULL) { return; } struct QueueNode *front = NULL, *rear = NULL; enqueue(&rear, root); while (front != NULL) { struct TreeNode *node = dequeue(&front); printf("%d ", node->val); if (node->left != NULL) { enqueue(&rear, node->left); } if (node->right != NULL) { enqueue(&rear, node->right); } } } ``` 四、实验结果 假设有如下二叉树: ``` 1 / \ 2 3 / \ \ 4 5 6 ``` 层序遍历的结果应该是:1 2 3 4 5 6。 、实验总结 本实验通过实现二叉树层序遍历算法,加深了对二叉树的理解,同时也掌握了用队列实现二叉树层序遍历的方法。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

猿憨憨

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值