ACM-problem P

problem:

The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000) cents to produce one unit of yogurt in week i. Yucky's factory, being well-designed, can produce arbitrarily many units of yogurt each week. 

Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt's warehouse is enormous, so it can hold arbitrarily many units of yogurt. 

Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any yogurt already in storage, can be used to meet Yucky's demand for that week.

input:

* Line 1: Two space-separated integers, N and S. <br> <br>* Lines 2..N+1: Line i+1 contains two space-separated integers: C_i and Y_i.

output:

* Line 1: Line 1 contains a single integer: the minimum total cost to satisfy the yogurt schedule. Note that the total might be too large for a 32-bit integer.

sample input:

4 5

88 200

89 400

97 300

91 500

sample output:

126900

在产奶时现在的价格和保存费用与未来一周的价格相比,如果花费更少,就扩大生产,把下一周的也产了。

代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
struct node
{
    int ci,yi;
 }a[10000+10];
 int main()
{
int n,s;
int i;
long long sum;
while( cin>>n>>s)
{
for(i=0;i<n;i++)
cin>>a[i].ci>>a[i].yi;
int t=0;
sum=0;
for(i=0;i<n-1;i++)
{
if(t==a[i].yi)
t=0;
else
sum+=a[i].ci*a[i].yi;
if((a[i].ci+s)<a[i+1].ci)
{
sum+=(a[i].ci+s)*a[i+1].yi;
t=a[i+1].yi;
}
}
if(t!=a[n-1].yi)
sum+=a[n-1].ci*a[n-1].yi;
cout<<sum;
     }
 
 }

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值