poj 2586 Y2K Accounting Bug

Y2K Accounting Bug
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13247 Accepted: 6725

Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc. 
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite. 

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input

59 237
375 743
200000 849694
2500000 8000000

Sample Output

116
28
300612
Deficit

Source

提示

题意:
美国计算机协会(ACM)遭到千年虫问题困扰以及MS公司丢失了准备好的年度报告上的一部分重要数据。
他们记得的是1999年的每个月公布的盈利和亏损情况,并且每个月公布的盈利s和亏损d是一样的。但他们却不记得哪几个月是盈利还是亏损。MS公司与其他公司不同的是他们是以5个月的盈利情况来发布(例如1月-5月,2月-6月...8月-12月)。美国计算机协会所知道的是他们发表的8次并且每一次都是亏损但不知亏多少,在MS首席程序师看来盈利的可能性不是很大。
那么问题来了,请问有没有可能有盈利的情况,如果有请输出可能盈利的最大值,不能的话输出Deficit.
思路:
题意表示看不懂,去看博客时才清楚,英语不好是硬伤啊。既然知道题意也就容易多了,我们假设在每五个月的后几个月是亏损的,那么细心的同学就会发现有这么几种情况:
 123456789101112
aSSSSDSSSSDSS
bSSSDDSSSDDSS
cSSDDDSSDDDSS
dSDDDDSDDDDSD
eDDDDDDDDDDDD
(注:S为盈利的情况,D就为亏损的情况)
接下来就可以敲代码了。

示例程序

Source Code

Problem: 2586		Code Length: 589B
Memory: 392K		Time: 0MS
Language: GCC		Result: Accepted
#include <stdio.h>
int main()
{
    int num,s,d;
    while(scanf("%d %d",&s,&d)!=EOF)
    {
        if(s*4-d<0)
        {
            num=s*10-d*2;
        }
        else if(s*3-2*d<0)
        {
            num=s*8-d*4;
        }
        else if(s*2-3*d<0)
        {
            num=s*6-d*6;
        }
        else if(s*1-4*d<0)
        {
            num=s*3-d*9;
        }
        else
        {
            num=-12*d;
        }
        if(num>=0)
        {
            printf("%d\n",num);
        }
        else
        {
            printf("Deficit\n");
        }
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值