poj 3026 Borg Maze

Borg Maze
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12608 Accepted: 4121

Description

The Borg is an immensely powerful race of enhanced humanoids from the delta quadrant of the galaxy. The Borg collective is the term used to describe the group consciousness of the Borg civilization. Each Borg individual is linked to the collective by a sophisticated subspace network that insures each member is given constant supervision and guidance. 

Your task is to help the Borg (yes, really) by developing a program which helps the Borg to estimate the minimal cost of scanning a maze for the assimilation of aliens hiding in the maze, by moving in north, west, east, and south steps. The tricky thing is that the beginning of the search is conducted by a large group of over 100 individuals. Whenever an alien is assimilated, or at the beginning of the search, the group may split in two or more groups (but their consciousness is still collective.). The cost of searching a maze is definied as the total distance covered by all the groups involved in the search together. That is, if the original group walks five steps, then splits into two groups each walking three steps, the total distance is 11=5+3+3.

Input

On the first line of input there is one integer, N <= 50, giving the number of test cases in the input. Each test case starts with a line containg two integers x, y such that 1 <= x,y <= 50. After this, y lines follow, each which x characters. For each character, a space `` '' stands for an open space, a hash mark ``#'' stands for an obstructing wall, the capital letter ``A'' stand for an alien, and the capital letter ``S'' stands for the start of the search. The perimeter of the maze is always closed, i.e., there is no way to get out from the coordinate of the ``S''. At most 100 aliens are present in the maze, and everyone is reachable.

Output

For every test case, output one line containing the minimal cost of a succesful search of the maze leaving no aliens alive.

Sample Input

2
6 5
##### 
#A#A##
# # A#
#S  ##
##### 
7 7
#####  
#AAA###
#    A#
# S ###
#     #
#AAA###
#####  

Sample Output

8
11

Source

提示

题意:

大致意思就是计算S和A点所生成图的最少路径和。

思路:

需要你要利用BFS先计算要做最小生成树的图点与点之间的边,之后才是喜闻乐见的prim算法。

开数组要开101*101,因为A+S最大为101,我喜欢节省内存的我没考虑S这一点100*100一直RE。。。

示例程序

Source Code

Problem: 3026		Code Length: 2607B
Memory: 464K		Time: 0MS
Language: GCC		Result: Accepted
#include <stdio.h>
#include <string.h>
#define MAX 1000000007
int id[101][101],alien[101][101];		//id[101][101]记录编号,alien[101][101]为要做最小生成树的图
char map[50][51];
void bfs(int x,int y,int n,int m)
{
    int q[4000][3],v[50][50],a,b,f=0,top=0;
    memset(v,0,sizeof(v));
    q[top][0]=x;
    q[top][1]=y;
    q[top][2]=0;
    v[x][y]=1;
    top++;
    while(f<top)
    {
        a=q[f][0];
        b=q[f][1];
        if(id[a][b]!=-1)
        {
            alien[id[x][y]][id[a][b]]=q[f][2];
        }
        if(a+1<m&&v[a+1][b]==0&&map[a+1][b]!='#')
        {
            q[top][0]=a+1;
            q[top][1]=b;
            q[top][2]=q[f][2]+1;
            top++;
            v[a+1][b]=1;
        }
        if(a-1>=0&&v[a-1][b]==0&&map[a-1][b]!='#')
        {
            q[top][0]=a-1;
            q[top][1]=b;
            q[top][2]=q[f][2]+1;
            top++;
            v[a-1][b]=1;
        }
        if(b+1<n&&v[a][b+1]==0&&map[a][b+1]!='#')
        {
            q[top][0]=a;
            q[top][1]=b+1;
            q[top][2]=q[f][2]+1;
            top++;
            v[a][b+1]=1;
        }
        if(b-1>=0&&v[a][b-1]==0&&map[a][b-1]!='#')
        {
            q[top][0]=a;
            q[top][1]=b-1;
            q[top][2]=q[f][2]+1;
            top++;
            v[a][b-1]=1;
        }
        f++;
    }
}
int prim(int n)
{
    int v[101],d[101],i,i1,k,t,sum=0;
    for(i=0;n>i;i++)
    {
        v[i]=0;
        d[i]=MAX;
    }
    d[0]=0;
    for(i=0;n>i;i++)
    {
        t=MAX;
        for(i1=0;n>i1;i1++)
        {
            if(v[i1]==0&&t>d[i1])
            {
                t=d[i1];
                k=i1;
            }
        }
        v[k]=1;
        sum=sum+t;
        for(i1=0;n>i1;i1++)
        {
            if(v[i1]==0&&d[i1]>alien[k][i1])
            {
                d[i1]=alien[k][i1];
            }
        }
    }
    return sum;
}
int main()
{
    int t,i,n,m,i1,i2,k;
    scanf("%d",&t);
    for(i=1;t>=i;i++)
    {
        memset(id,-1,sizeof(id));
        k=0;
        scanf("%d %d",&n,&m);
        gets(map[0]);		//吸收上面的回车
        for(i1=0;m>i1;i1++)
        {
            gets(map[i1]);
        }
        for(i1=0;m>i1;i1++)
        {
            for(i2=0;n>i2;i2++)
            {
                if(map[i1][i2]=='A'||map[i1][i2]=='S')		//对S和alien编号
                {
                    id[i1][i2]=k;
                    k++;
                }
            }
        }
        for(i1=0;m>i1;i1++)
        {
            for(i2=0;n>i2;i2++)
            {
                if(id[i1][i2]!=-1)
                {
                    bfs(i1,i2,n,m);			//计算S和alien两两之间的最短距离
                }
            }
        }
        printf("%d\n",prim(k));
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值