poj 1573 Robot Motion

Robot Motion
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12567 Accepted: 6094

Description


A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are 

N north (up the page) 
S south (down the page) 
E east (to the right on the page) 
W west (to the left on the page) 

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid. 

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits. 

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around. 

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

Sample Input

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 0

Sample Output

10 step(s) to exit
3 step(s) before a loop of 8 step(s)

Source

提示

题意:

已经设计好程序的一个机器人,把它放入一个图中,图中遵循这样的规则:

字母N:向上走一格。

字母S:向下走一格。

字母E:向右走一格。

字母W:向左走一格。

如果不能走出图输出(走到循环点的步数) step(s) before a loop of (循环一次的步数) step(s),如果能走出输出(走的步数)step(s) to exit。

思路:

水题,且步数为1时也要带上(s)。

示例程序

Source Code

Problem: 1573		Code Length: 1647B
Memory: 392K		Time: 0MS
Language: GCC		Result: Accepted
Source Code
#include <stdio.h>
#include <string.h>
int main()
{
    int n,m,y,i,v[10][10],step,loop,x;
    char map[10][11];
    scanf("%d %d %d",&n,&m,&y);
    while(n!=0||m!=0||y!=0)
    {
        step=0;
        loop=0;
        x=0;
        y--;
        memset(v,0,sizeof(v));
        for(i=0;n>i;i++)
        {
            scanf("%s",map[i]);
        }
        while(v[x][y]==0)
        {
            v[x][y]=1;
            if(map[x][y]=='E')
            {
                y++;
            }
            else if(map[x][y]=='N')
            {
                x--;
            }
            else if(map[x][y]=='W')
            {
                y--;
            }
            else
            {
                x++;
            }
            step++;
            if(x>=n||y>=m||y<0||x<0)
            {
                loop=-1;
                break;
            }
        }
        if(loop==-1)
        {
            printf("%d step(s) to exit\n",step);
        }
        else
        {
            memset(v,0,sizeof(v));
            while(v[x][y]==0)
            {
                v[x][y]=1;
                if(map[x][y]=='E')
                {
                    y++;
                }
                else if(map[x][y]=='N')
                {
                    x--;
                }
                else if(map[x][y]=='W')
                {
                    y--;
                }
                else
                {
                    x++;
                }
                loop++;
            }
            printf("%d step(s) before a loop of %d step(s)\n",step-loop,loop);
        }
        scanf("%d %d %d",&n,&m,&y);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值