poj 2151 Check the difficulty of problems

Check the difficulty of problems
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6679 Accepted: 2905

Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms: 
1. All of the teams solve at least one problem. 
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems. 

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem. 

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems? 

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output

0.972

Source

POJ Monthly,鲁小石

提示

题意:

组织一次程序设计大赛可不是什么容易的事,为了避免题目太难,一般都遵循以下规则:

1.所有的团队都能做出一题。(传说中的签到题)

2.冠军队(做对题数量最多的,没有罚时吗?)做对题数量不会太少。(就是不会出现大家只做对1,2道题,冠军队只比其他人多对1,2道题)

现在组织者已经给出了比赛的题目,并通过初步比赛的结果,组织者可以估计团队可以成功地解决问题的概率。你能计算出在所有队伍都至少解出一道,且冠军队伍解出n(0<n<=m)道题的概率吗?

思路:

这题不是哈希,是概率dp,说到dp可是我的弱项,我也就只有去百度了。

首先我们设dp[i][j][k]为第 i 组做了 j 题成功AC k 题的概率。用另一个数组f[i][j]存下第 i 组做对第 j 题的概率。

递推式就有:dp[i][j][k] = dp[i][j-1][k-1]*(f[i][j])+dp[i][j-1][k]*(1-f[i][j])

最后所有团队都至少做对1题的概率减去所有团队都至少做对1~n-1道题的概率就完了。

用%f输出。用%f输出。用%f输出。

示例程序

Source Code

Problem: 2151		Code Length: 1085B
Memory: 8176K		Time: 47MS
Language: GCC		Result: Accepted
Source Code
#include <stdio.h>
#include <string.h>
double dp[1000][31][31],f[1000][31];
int main()
{
    int n,m,t,i,i1,i2;
    double p1,p2,sum;
    scanf("%d %d %d",&m,&t,&n);
    while(n!=0||t!=0||m!=0)
    {
        p1=1;
        p2=1;
        for(i=0;t>i;i++)
        {
            for(i1=1;m>=i1;i1++)
            {
                scanf("%lf",&f[i][i1]);
            }
        }
        for(i=0;t>i;i++)
        {
            dp[i][0][0]=1;
            for(i1=1;m>=i1;i1++)
            {
                dp[i][i1][0]=dp[i][i1-1][0]*(1-f[i][i1]);
                for(i2=1;i1>=i2;i2++)
                {
                    dp[i][i1][i2]=dp[i][i1-1][i2-1]*f[i][i1]+dp[i][i1-1][i2]*(1-f[i][i1]);
                }
            }
        }
        for(i=0;t>i;i++)
        {
            p1=p1*(1-dp[i][m][0]);
        }
        for(i=0;t>i;i++)
        {
            sum=0;
            for(i1=1;n>i1;i1++)
            {
                sum=sum+dp[i][m][i1];
            }
            p2=p2*sum;
        }
        printf("%.3f\n",p1-p2);
        scanf("%d %d %d",&m,&t,&n);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值