poj 1442 Black Box

Black Box
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 10337 Accepted: 4257

Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions: 

ADD (x): put element x into Black Box; 
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending.

Let us examine a possible sequence of 11 transactions: 

Example 1 
N Transaction i Black Box contents after transaction Answer 

      (elements are arranged by non-descending)   

1 ADD(3)      0 3   

2 GET         1 3                                    3 

3 ADD(1)      1 1, 3   

4 GET         2 1, 3                                 3 

5 ADD(-4)     2 -4, 1, 3   

6 ADD(2)      2 -4, 1, 2, 3   

7 ADD(8)      2 -4, 1, 2, 3, 8   

8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8   

9 GET         3 -1000, -4, 1, 2, 3, 8                1 

10 GET        4 -1000, -4, 1, 2, 3, 8                2 

11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8   

It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type. 


Let us describe the sequence of transactions by two integer arrays: 


1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2). 

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6). 

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence. 


Input

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.

Output

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.

Sample Input

7 4
3 1 -4 2 8 -1000 2
1 2 6 6

Sample Output

3
3
1
2

Source

提示

题意:

题目太长就不废话了。

给你一串数,有m(m<=30000)个数要成立一个序列,有n(n<=m)个询问,每次询问输入一个数,表示插入第几个数时输出第i个小的数。

看样例:第一次询问输入的数为1,那么插入第一个数时第一小的就是3(因为只有它自己),第二次输入2,那么插入第二个数时第二小的还是3,因为序列为3,1。

思路:

需要保证让序列一直有序才方便输出,所以需要优先队列。并且用数组模拟依然是T!L!E!

但是C++的queue要怎么取第几位的数?

一个优先队列不够,那就两个,一个是从小到大的优先队列,另一个则是从大到小,数据在它们之间相互传递可以很快的找到我们所要的,详细过程你只要用样例去人工运行一下思路就很清晰了。

示例程序

Source Code

Problem: 1442		Code Length: 811B
Memory: 920K		Time: 344MS
Language: G++		Result: Accepted
#include <cstdio>
#include <queue>
using namespace std;
int main()
{
    int n,m,a[30000],x,i,i1,t,top=0;
    priority_queue<int,vector<int>,less<int> >bigq;				//从大到小的优先队列
    priority_queue<int,vector<int>,greater<int> >smallq;			//从小到大的优先队列
    scanf("%d %d",&m,&n);
    for(i=0;m>i;i++)
    {
        scanf("%d",&a[i]);
    }
    for(i=1;n>=i;i++)
    {
        scanf("%d",&x);
        for(i1=top;x>i1;i1++)
        {
            smallq.push(a[i1]);
            if(bigq.empty()==0&&smallq.top()<bigq.top())		//这里设置的非常巧妙
            {
                t=bigq.top();
                bigq.pop();
                bigq.push(smallq.top());
                smallq.pop();
                smallq.push(t);
            }
        }
        top=i1;
        printf("%d\n",smallq.top());
        bigq.push(smallq.top());			//输出以后就不要了
        smallq.pop();
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值