POJ1442——Black Box

Black Box
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 10621 Accepted: 4377

Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions: 

ADD (x): put element x into Black Box; 
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending. 

Let us examine a possible sequence of 11 transactions: 

Example 1 
N Transaction i Black Box contents after transaction Answer 

      (elements are arranged by non-descending)   

1 ADD(3)      0 3   

2 GET         1 3                                    3 

3 ADD(1)      1 1, 3   

4 GET         2 1, 3                                 3 

5 ADD(-4)     2 -4, 1, 3   

6 ADD(2)      2 -4, 1, 2, 3   

7 ADD(8)      2 -4, 1, 2, 3, 8   

8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8   

9 GET         3 -1000, -4, 1, 2, 3, 8                1 

10 GET        4 -1000, -4, 1, 2, 3, 8                2 

11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8   

It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type. 


Let us describe the sequence of transactions by two integer arrays: 


1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2). 

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6). 

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence. 


Input

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.

Output

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.

Sample Input

7 4
3 1 -4 2 8 -1000 2
1 2 6 6

Sample Output

3
3
1
2

Source


题意:

给你一串数,有m(m<=30000)个数要成立一个序列,有n(n<=m)个询问,每次询问输入一个数,表示插入第几个数时输出第i个小的数。

以样例为例:输入第一个数  3  求起一个的数  为 3,  输入第二个数  1,求第二小的数为 3, 输入第6个数,因为6之前还有数没检测,所以要先进队,然后再输出第三小的数 1,。。。。。。。

例如S[1..n] = 1,2,3,4,5,6,7,index = 4,则大顶堆为{1,2,3},小顶堆为{4,5,6,7}为什么要这样维护呢?因为当小堆最小的元素都大于大堆最大的元素时,那么序列中排第index个数就是小堆最小的数了。
   我们假设第 k 次询问后,有以下情景:大顶堆:S[1..k],堆顶元素为S[k],小顶堆:S[k+1,n],堆顶元素为S[k+1],然后每当添加一个元素new时,先添加到大顶堆中,这时如果出现大顶堆数大于小顶堆的数时,理应交换。


#include <iostream>
#include <cstdio>
#include <queue>
#include <vector>

using namespace std;

int main()
{
    priority_queue<int, vector<int>,less<int> > mx;      //大数优先
    priority_queue<int, vector<int>,greater<int> >mn;   //小数优先
    int m, n, top = 0;
    cin>>m>>n;
    int *a = new int[m];
    for( int i = 0;i < m;i++ )
        cin>>a[i];
    for( int j = 0;j < n;j++ )
    {
        int x;
        cin>>x;
        int i;
        for( i = top;i < x;i++ )
        {
            mn.push(a[i]);
            if( !mx.empty()&&mx.top()>mn.top() )       //核心
            {
                int t1 = mn.top();
                mn.pop();
                int t2 = mx.top();
                mx.pop();
                mn.push(t2);
                mx.push(t1);
            }
        }
        top = i;
        cout<<mn.top()<<endl;
        mx.push(mn.top());
        mn.pop();     //输出之后就没用了,出队
    }


    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值