poj 2488 A Knight's Journey

A Knight's Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 41118 Accepted: 13990

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany

提示

题意:

骑士对8*8的棋盘感到厌倦了,世界那么大他想去走走,骑士来到了一个p(行)*q(列)(1<=p*q<=26)大的棋盘,他可以以棋盘上的任何位子作为起点,给出终点,看看他能不能遍历所有的格子。(骑士的走法和中国象棋的马一样)

能遍历所有格子,输出遍历的顺序,若不唯一,先以列最小,后以行最小遍历的方式输出。

思路:

从优先列最小,最后行最小的方式枚举起点,之后DFS去搜就行了,注意输出代码的位置,我就因为这点一直想不通连样例都不能过。

示例程序

Source Code

Problem: 2488		Code Length: 1374B
Memory: 396K		Time: 16MS
Language: GCC		Result: Accepted
#include <stdio.h>
#include <string.h>
struct
{
    int x,y;
}s[676];
int bug,v[26][26],p,q,walk[8][2]={{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};			//这里只需注意是以列为最小来遍历
void dfs(int x,int y,int top)
{
    int i,a,b;
    if(bug==1)
    {
        return;
    }
    if(top==p*q)
    {
        for(i=0;p*q>i;i++)					//只能一有答案就输出,不然里面的数据会被替换
        {
            printf("%c%d",s[i].y+'A',s[i].x+1);
        }
        bug=1;
        return;
    }
    for(i=0;8>i;i++)
    {
        a=x+walk[i][0];
        b=y+walk[i][1];
        if(a>=0&&a<p&&b>=0&&b<q&&v[a][b]==0)
        {
            v[a][b]=1;
            s[top].y=b;
            s[top].x=a;
            dfs(a,b,top+1);
            v[a][b]=0;
        }
    }
}
int main()
{
    int n,i,i1,i2;
    scanf("%d",&n);
    for(i=1;n>=i;i++)
    {
        bug=0;
        scanf("%d %d",&p,&q);
        printf("Scenario #%d:\n",i);
        memset(v,0,sizeof(v));
        for(i1=0;q>i1;i1++)
        {
            for(i2=0;p>i2;i2++)
            {
                s[0].y=i1;
                s[0].x=i2;
                v[i2][i1]=1;
                dfs(i2,i1,1);
                if(bug==1)
                {
                    break;
                }
            }
            if(bug==1)
            {
                break;
            }
        }
        if(bug==0)
        {
            printf("impossible");
        }
        printf("\n\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值