poj 3009 Curling 2.0

Curling 2.0
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17893 Accepted: 7355

Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board 
First row of the board
 
... 
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0vacant square
1block
2start position
3goal position

The dataset for Fig. D-1 is as follows:

6 6 
1 0 0 2 1 0 
1 1 0 0 0 0 
0 0 0 0 0 3 
0 0 0 0 0 0 
1 0 0 0 0 1 
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output

1
4
-1
4
10
-1

Source

提示

题意:

还记得口袋妖怪绿宝石(红宝石,蓝宝石等)那个看看洞吗:

这题就是那样,每走一步只有遇到终点或者前面的石头才会停下来(边界不算,也就是说出界也不会停下来),只是多了遇到前面的石头就会不自觉的使用碎岩术把它给打坏,求最少到终点的步数。如果超过10步意味着出不去了。

思路:

DFS搜索,想用BFS很难,要去一直维护地图,很麻烦,DFS只要搜完就可以恢复到之前的状态,所以我们需要遍历所有的走法,比较出其中最少的一次。要注意题目的超过10步,题目自带剪枝,不然1s显然太少了,并且前面要有空地才能对前方的石头造成伤害,和石头面对面是打不坏的。

示例程序

Source Code

Problem: 3009		Code Length: 1680B
Memory: 392K		Time: 125MS
Language: GCC		Result: Accepted
#include <stdio.h>
#include <string.h>
int tx,ty,map[20][20],w,h,min,walk[4][2]={{0,-1},{0,1},{1,0},{-1,0}};			//手动输入走法
void dfs(int x,int y,int step)
{
    int i,a,b;
    if(step>10)					//超过10次就不要去搜了
    {
        return;
    }
    for(i=0;4>i;i++)
    {
        a=x;
        b=y;
        while(1)
        {
            a=a+walk[i][0];
            b=b+walk[i][1];
            if(a<0||a>=h||b<0||b>=w)			//出界就没法停下来,也就到不了终点
            {
                break;
            }
            else if(a==tx&&b==ty)
            {
                if(min>step)
                {
                    min=step;
                }
                return;					//这个方向能到终点就回去,就算另外的方向如果能到终点步数也比这个步数多
            }
            else if(map[a][b]==1)
            {
                if(a-walk[i][0]!=x||b-walk[i][1]!=y)			//需要缓冲才能打碎石头
                {
                    map[a][b]=0;
                    dfs(a-walk[i][0],b-walk[i][1],step+1);
                    map[a][b]=1;
                }
                break;
            }
        }
    }
}
int main()
{
    int sx,sy,i,i1;
    scanf("%d %d",&w,&h);
    while(w!=0||h!=0)
    {
        min=1000000007;
        for(i=0;h>i;i++)
        {
            for(i1=0;w>i1;i1++)
            {
                scanf("%d",&map[i][i1]);
                if(map[i][i1]==2)
                {
                    sx=i;
                    sy=i1;
                    map[i][i1]=0;			//记录起点位置,之后就可以把它当做冰面了
                }
                else if(map[i][i1]==3)
                {
                    tx=i;
                    ty=i1;
                }
            }
        }
        dfs(sx,sy,1);
        if(min==1000000007)
        {
            printf("-1\n");
        }
        else
        {
            printf("%d\n",min);
        }
        scanf("%d %d",&w,&h);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值