poj 2676 Sudoku

Sudoku
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 17997 Accepted: 8714 Special Judge

Description

Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task. 

Input

The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.

Output

For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.

Sample Input

1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107

Sample Output

143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843
854396127

Source

提示

题意:

数独问题,就是每行,每列,每个九宫格没有重复的数字。找出符合的答案,如果不唯一输出其中一个就行。

思路:

记录下要填数字的位置会比较方便些。

示例程序

Source Code

Problem: 2676		Code Length: 1560B
Memory: 392K		Time: 16MS
Language: GCC		Result: Accepted
#include <stdio.h>
#include <string.h>
struct
{
    int x,y;
}q[81];							//q[]用来记录所需填数字的位置
int r[9][9],c[9][9],sq[3][3][9],map[9][9],bug;
void dfs(int num)
{
    int i,i1,x1,y1;
    x1=q[num].x;
    y1=q[num].y;
    if(bug==1)					//找到就不要找了
    {
        return;
    }
    if(num==-1)
    {
        for(i=0;9>i;i++)
        {
            for(i1=0;9>i1;i1++)
            {
                printf("%d",map[i][i1]);
            }
            printf("\n");
        }
        bug=1;
        return;
    }
    for(i=0;9>i;i++)
    {
        if(r[x1][i]==0&&c[y1][i]==0&&sq[x1/3][y1/3][i]==0)				//要保证列,行,九宫格不会有重复的
        {
            r[x1][i]=1;
            c[y1][i]=1;
            sq[x1/3][y1/3][i]=1;
            map[x1][y1]=i+1;
            dfs(num-1);
            r[x1][i]=0;					//回溯
            c[y1][i]=0;
            sq[x1/3][y1/3][i]=0;
        }
    }
}
int main()
{
    int t,i,i1,i2,i3,num;
    scanf("%d",&t);
    for(i=1;t>=i;i++)
    {
        bug=0;
        num=0;
        memset(c,0,sizeof(c));						//行的数字重复记录
        memset(r,0,sizeof(r));						//列的数字重复记录
        memset(sq,0,sizeof(sq));					//9个九宫格的数字重复记录
        for(i1=0;9>i1;i1++)
        {
            for(i2=0;9>i2;i2++)
            {
                scanf("%1d",&map[i1][i2]);					//因为每格为1个数字,这里用%1d来限制输入
                if(map[i1][i2]!=0)
                {
                    r[i1][map[i1][i2]-1]=1;
                    c[i2][map[i1][i2]-1]=1;
                    sq[i1/3][i2/3][map[i1][i2]-1]=1;
                }
                else
                {
                    q[num].x=i1;
                    q[num].y=i2;
                    num++;
                }
            }
        }
        dfs(num-1);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值