poj 1837 Balance

Balance
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 13513 Accepted: 8468

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights. 
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
It is guaranteed that will exist at least one solution for each test case at the evaluation. 

Input

The input has the following structure: 
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm); 
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values. 

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2

Source

提示

题意:

一个杠以它的中点左右都长度都是15,你有c(2<=c<=20)个钩子(给出的是距离中点的长度,左边为负,右边为正),g(2<=g<=20)个砝码,有几种情况会是杠平衡。

这里平衡指的是,砝码的质量乘上砝码到中点的长度。

思路:

因为左边的距离为负,乘起来相加为0就行了,但需要DP也就没什么用。我们设DP[i][j],那 i 是挂上砝码的数量,j是平衡数值。砝码质量范围是1~25,数值最大就是20*25*20*15=7500,这是一边的,两边就是15000,那么我们把7500(有一边为负为了数组下标而不取)当做是达到平衡状态时候的数值。

状态方程:DP[i][j+w[i]*v[k]]=DP[i][j+w[i]*v[k]]+DP[i-1][j],至于过程戳。(DP学的不算好,这些也是百度后理解的)

示例程序

Source Code

Problem: 1837		Code Length: 633B
Memory: 1588K		Time: 47MS(141MS)				//括号里的是去掉if的运行时间
Language: GCC		Result: Accepted
#include <stdio.h>
#include <string.h>
int main()
{
    int c,g,w[20],v[20],dp[21][15001],i,i1,i2;
    scanf("%d %d",&c,&g);
    for(i=0;c>i;i++)
    {
        scanf("%d",&v[i]);
    }
    for(i=1;g>=i;i++)
    {
        scanf("%d",&w[i]);
    }
    memset(dp,0,sizeof(dp));
    dp[0][7500]=1;						//什么也不放就是一种
    for(i=1;g>=i;i++)
    {
        for(i1=0;15000>=i1;i1++)
        {
            if(dp[i-1][i1]!=0)
            {
                for(i2=0;c>i2;i2++)
                {
                    dp[i][i1+w[i]*v[i2]]=dp[i][i1+w[i]*v[i2]]+dp[i-1][i1];			//状态方程
                }
            }
        }
    }
    printf("%d",dp[g][7500]);
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值