poj 1159 Palindrome

Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 60664 Accepted: 21132

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

Source

提示

解析源于书。。。。。。

题意:

给定一个字符串,问最少插入多少个字符,使该字符串变成回文串。

思路:

设原字符串序列为X,逆序列为Y,则最少补充的字母数=X的长度-X和Y的最长公共子序列。这道题有意思的地方不是发现这个公式,而是对空间的压缩处理。数据范围达到了5000,若开静态数组用int肯定会超,但是short就会过了。最好的办法是用滚动数组。

滚动数组不会啊(看起来也挺简单的,got it!),只有用比较简单的方式去做,递推式为:

if(ch[i]!=ch[i1])
{
    dp[i][i1]=max(dp[i][i1-1],dp[i+1][i1]);
}
else
{
    dp[i][i1]=dp[i-1][i1-1]+1;
}

 ch[i]为顺序X的字符,ch[i1]为逆序Y的字符。 

示例程序

short类型的数组:
Source Code

Problem: 1159		Code Length: 627B
Memory: 49376K		Time: 1016MS
Language: GCC		Result: Accepted
#include <stdio.h>
#include <string.h>
short dp[5001][5001];
int max(int a,int b)
{
    if(a>b)
    {
        return a;
    }
    else
    {
        return b;
    }
}
int main()
{
    int n,i,i1;
    char ch[5001];
    scanf("%d",&n);
    scanf("%s",ch);
    memset(dp,0,sizeof(dp));
    for(i=0;n>i;i++)
    {
        for(i1=n-1;i1>=0;i1--)				//因为逆序的关系i1以及下面的数组与平时是相反的
        {
            if(ch[i]!=ch[i1])
            {
                dp[i+1][n-i1]=max(dp[i+1][n-i1-1],dp[i][n-i1]);
            }
            else
            {
                dp[i+1][n-i1]=dp[i][n-i1-1]+1;
            }
        }
    }
    printf("%d",n-dp[n][n]);
    return 0;
}

 滚动数组,代码源于书,经过修改(仅仅多了个取余,空间复杂度一下就降了下来,时间也就多了100ms): 
Source Code

Problem: 1159		Code Length: 636B
Memory: 396K		Time: 1110MS
Language: GCC		Result: Accepted
#include <stdio.h>
#include <string.h>
int max(int a,int b)
{
    if(a>b)
    {
        return a;
    }
    else
    {
        return b;
    }
}
int main()
{
    int n,i,i1,dp[2][5001];
    char ch[5001];
    scanf("%d",&n);
    scanf("%s",ch);
    memset(dp,0,sizeof(dp));
    for(i=0;n>i;i++)
    {
        for(i1=n-1;i1>=0;i1--)
        {
            if(ch[i]!=ch[i1])
            {
                dp[(i+1)%2][n-i1]=max(dp[(i+1)%2][n-i1-1],dp[i%2][n-i1]);
            }
            else
            {
                dp[(i+1)%2][n-i1]=dp[i%2][n-i1-1]+1;
            }
        }
    }
    printf("%d",n-dp[n%2][n]);
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值