poj 3292 Semi-prime H-numbers

Semi-prime H-numbers
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8819 Accepted: 3883

Description

This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.

As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.

For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three H-primes.

Input

Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

Output

For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

Sample Input

21 
85
789
0

Sample Output

21 0
85 5
789 62

Source

提示

题意:

有一个4n+1的集合(1,5,9,13,17......),我们定义集合里除了1和它本身不能被其他数(仅限集合里)整除的我们把它叫做H-primes(不包括1),两个相乘的H-primes数我们把它叫做H-semi-prime,集合里的其他数就叫做H-composites,那么给出一个数,求出1~n(n<=1000001)之间有几个H-semi-prime?

思路:

看不懂题目太痛苦了,还以为H-primes就是素数,想了半天没头绪,去百度才知道这题不难。

用一个数组记录它是H-primes,还是H-semi-prime,打表暴力,没什么好说的。

示例程序

Source Code

Problem: 3292		Code Length: 780B
Memory: 4304K		Time: 47MS
Language: GCC		Result: Accepted
#include <stdio.h>
#include <string.h>
int a[1000001];
int main()
{
    int i,i1,n,num=0;
    memset(a,0,sizeof(a));				//0为H-primes,1为H-semi-prime,-1为H-composites
    for(i=5;1000001>=i;i=i+4)
    {
        for(i1=5;1000001>=i1;i1=i1+4)
        {
            if(i*i1>1000001)
            {
                break;
            }
            if(a[i-1]==0&&a[i1-1]==0)
            {
                a[i*i1-1]=1;
            }
            else
            {
                a[i*i1-1]=-1;
            }
        }
    }
    for(i=5;1000001>=i;i++)
    {
        if(a[i-1]==1)
        {
            a[i-1]=a[i-1]+num;
            num++;					//num用来计数
        }
        else
        {
            a[i-1]=num;
        }
    }
    scanf("%d",&n);
    while(n!=0)
    {
        printf("%d %d\n",n,a[n-1]);
        scanf("%d",&n);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值