poj 1408 Fishnet

Fishnet
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 2138 Accepted: 1348

Description

A fisherman named Etadokah awoke in a very small island. He could see calm, beautiful and blue sea around the island. The previous night he had encountered a terrible storm and had reached this uninhabited island. Some wrecks of his ship were spread around him. He found a square wood-frame and a long thread among the wrecks. He had to survive in this island until someone came and saved him. 

In order to catch fish, he began to make a kind of fishnet by cutting the long thread into short threads and fixing them at pegs on the square wood-frame. He wanted to know the sizes of the meshes of the fishnet to see whether he could catch small fish as well as large ones. 

The wood frame is perfectly square with four thin edges on meter long: a bottom edge, a top edge, a left edge, and a right edge. There are n pegs on each edge, and thus there are 4n pegs in total. The positions of pegs are represented by their (x,y)-coordinates. Those of an example case with n=2 are depicted in figures below. The position of the ith peg on the bottom edge is represented by (ai,0). That on the top edge, on the left edge and on the right edge are represented by (bi,1), (0,ci) and (1,di), respectively. The long thread is cut into 2n threads with appropriate lengths. The threads are strained between (ai,0) and (bi,1),and between (0,ci) and (1,di) (i=1,...,n). 

You should write a program that reports the size of the largest mesh among the (n+1)2 meshes of the fishnet made by fixing the threads at the pegs. You may assume that the thread he found is long enough to make the fishnet and the wood-frame is thin enough for neglecting its thickness. 
 

Input

The input consists of multiple sub-problems followed by a line containing a zero that indicates the end of input. Each sub-problem is given in the following format. 

a1 a2 ... an 
b1 b2 ... bn 
c1 c2 ... cn 
d1 d2 ... dn 
you may assume 0 < n <= 30, 0 < ai,bi,ci,di < 1

Output

For each sub-problem, the size of the largest mesh should be printed followed by a new line. Each value should be represented by 6 digits after the decimal point, and it may not have an error greater than 0.000001.

Sample Input

2
0.2000000 0.6000000
0.3000000 0.8000000
0.1000000 0.5000000
0.5000000 0.6000000
2
0.3333330 0.6666670
0.3333330 0.6666670
0.3333330 0.6666670
0.3333330 0.6666670
4
0.2000000 0.4000000 0.6000000 0.8000000
0.1000000 0.5000000 0.6000000 0.9000000
0.2000000 0.4000000 0.6000000 0.8000000
0.1000000 0.5000000 0.6000000 0.9000000
2
0.5138701 0.9476283
0.1717362 0.1757412
0.3086521 0.7022313
0.2264312 0.5345343
1
0.4000000
0.6000000
0.3000000
0.5000000
0

Sample Output

0.215657
0.111112
0.078923
0.279223
0.348958

Source

提示

题意:

有1*1的正方形在a,b,c,d边给出4*n(0<n<=30)个点,a边与b边的点连线,c边与d边连线,会产生(n+1)^2四边形,求出其中最大的一个。

保证数据不会有顶点的情况。

思路:

以坐标储存下点,先求出相连直线相交形成的交点,当然还是用刚才的方法,之后利用多边形面积的三角形剖分用向量计算,把所有的点进行枚举,找出最大的就行了。

示例程序

Source Code

Problem: 1408		Code Length: 1840B
Memory: 420K		Time: 0MS
Language: GCC		Result: Accepted
#include <stdio.h>
#include <math.h>
struct point
{
    double x,y;
}p[32][32];
void init(int n)
{
    p[0][0].x=0;
    p[0][0].y=0;
    p[0][n+1].x=1;
    p[0][n+1].y=0;
    p[n+1][0].x=0;
    p[n+1][0].y=1;
    p[n+1][n+1].x=1;
    p[n+1][n+1].y=1;
}
struct point intersection(struct point a,struct point b,struct point c,struct point d)
{
    double A1,B1,C1,A2,B2,C2;
    struct point t;
    A1=b.y-a.y;
    B1=a.x-b.x;
    C1=b.x*a.y-a.x*b.y;
    A2=d.y-c.y;
    B2=c.x-d.x;
    C2=d.x*c.y-c.x*d.y;
    t.x=(B1*C2-B2*C1)/(A1*B2-A2*B1);
    t.y=(A2*C1-A1*C2)/(A1*B2-A2*B1);
    return t;
}
double cross(struct point a,struct point b,struct point o)
{
    return fabs((a.x-o.x)*(b.y-o.y)-(b.x-o.x)*(a.y-o.y));		//向量积可能会有负数的情况
}
int main()
{
    int n,i,i1;
    double max,s;
    scanf("%d",&n);
    while(n!=0)
    {
        init(n);					//初始化,把4个顶点坐标输入进去
        max=0;
        for(i=1;n>=i;i++)				//a边
        {
            scanf("%lf",&p[0][i].x);
            p[0][i].y=0;
        }
        for(i=1;n>=i;i++)				//b边
        {
            scanf("%lf",&p[n+1][i].x);
            p[n+1][i].y=1;
        }
        for(i=1;n>=i;i++)				//c边
        {
            scanf("%lf",&p[i][0].y);
            p[i][0].x=0;
        }
        for(i=1;n>=i;i++)				//d边
        {
            scanf("%lf",&p[i][n+1].y);
            p[i][n+1].x=1;
        }
        for(i=1;n>=i;i++)
        {
            for(i1=1;n>=i1;i1++)
            {
                p[i][i1]=intersection(p[0][i1],p[n+1][i1],p[i][0],p[i][n+1]);		//计算交点
            }
        }
        for(i=1;n+1>=i;i++)
        {
            for(i1=1;n+1>=i1;i1++)
            {
                s=(cross(p[i-1][i1-1],p[i][i1-1],p[i][i1])+cross(p[i-1][i1-1],p[i-1][i1],p[i][i1]))/2;	//枚举面积,注意要除2
                if(s>max)
                {
                    max=s;
                }
            }
        }
        printf("%.6f\n",max);
        scanf("%d",&n);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值