poj 1364 King

King
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12431 Accepted: 4511

Description

Once, in one kingdom, there was a queen and that queen was expecting a baby. The queen prayed: ``If my child was a son and if only he was a sound king.'' After nine months her child was born, and indeed, she gave birth to a nice son. 
Unfortunately, as it used to happen in royal families, the son was a little retarded. After many years of study he was able just to add integer numbers and to compare whether the result is greater or less than a given integer number. In addition, the numbers had to be written in a sequence and he was able to sum just continuous subsequences of the sequence. 

The old king was very unhappy of his son. But he was ready to make everything to enable his son to govern the kingdom after his death. With regards to his son's skills he decided that every problem the king had to decide about had to be presented in a form of a finite sequence of integer numbers and the decision about it would be done by stating an integer constraint (i.e. an upper or lower limit) for the sum of that sequence. In this way there was at least some hope that his son would be able to make some decisions. 

After the old king died, the young king began to reign. But very soon, a lot of people became very unsatisfied with his decisions and decided to dethrone him. They tried to do it by proving that his decisions were wrong. 

Therefore some conspirators presented to the young king a set of problems that he had to decide about. The set of problems was in the form of subsequences Si = {aSi, aSi+1, ..., aSi+ni} of a sequence S = {a1, a2, ..., an}. The king thought a minute and then decided, i.e. he set for the sum aSi + aSi+1 + ... + aSi+ni of each subsequence Si an integer constraint ki (i.e. aSi + aSi+1 + ... + aSi+ni < ki or aSi + aSi+1 + ... + aSi+ni > ki resp.) and declared these constraints as his decisions. 

After a while he realized that some of his decisions were wrong. He could not revoke the declared constraints but trying to save himself he decided to fake the sequence that he was given. He ordered to his advisors to find such a sequence S that would satisfy the constraints he set. Help the advisors of the king and write a program that decides whether such a sequence exists or not. 

Input

The input consists of blocks of lines. Each block except the last corresponds to one set of problems and king's decisions about them. In the first line of the block there are integers n, and m where 0 < n <= 100 is length of the sequence S and 0 < m <= 100 is the number of subsequences Si. Next m lines contain particular decisions coded in the form of quadruples si, ni, oi, ki, where oi represents operator > (coded as gt) or operator < (coded as lt) respectively. The symbols si, ni and ki have the meaning described above. The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the blocks in the input. A line contains text successful conspiracy when such a sequence does not exist. Otherwise it contains text lamentable kingdom. There is no line in the output corresponding to the last ``null'' block of the input.

Sample Input

4 2
1 2 gt 0
2 2 lt 2
1 2
1 0 gt 0
1 0 lt 0
0

Sample Output

lamentable kingdom
successful conspiracy

Source

提示

题意:

有一个国度,老国王有一个比较智障的儿子,老国王死后大家对新国王的提议表示不满。新国王的问题是有一个序列s,从其中取出s的子序列si(a(si),a(si+1)...a(si+ni)),并给出ki,ki要么大于si序列之和,要么小于si序列之和。求出是否有满足上述条件的序列,有输出“lamentable kingdom”,否则输出“successful conspiracy”。

思路:

如果不把这题归为差分约束系统还不知道怎么做呢,要建立超级源点,且包括超级源点在内有n+2个点(其中的奥秘也不是很明白,多加一个点就成了)。

不等式组:

1.sum[0]-sum[i]<=0

2.sum[si]-sum[si+ni+1]<=ki-1

3.sum[si+ni+1]-sum[si]<=-ki-1

没有等号一定要想办法给它搞上。之后就是成环判定,至于最短(负环)还是最长(正环)看个人爱好了。

示例程序

Source Code

Problem: 1364		Code Length: 1802B
Memory: 360K		Time: 0MS
Language: GCC		Result: Accepted
#include <stdio.h>
#include <string.h>
#define MAX 1000000007
struct
{
    int v,d,next;
}w[350];
int h[100],numw;
void insert(int u,int v,int d)
{
    w[numw].v=v;
    w[numw].d=d;
    w[numw].next=h[u];
    h[u]=numw;
    numw++;
}
int spfa(int n)
{
    int pos,pos1,i,d[100],v[100],num[100],q[10000],f=0,top=0;
    for(i=0;n>i;i++)
    {
        d[i]=MAX;
        v[i]=0;
        num[i]=0;
    }
    v[0]=1;
    d[0]=0;
    num[0]++;
    q[top]=0;
    top++;
    while(f<top)
    {
        pos=q[f];
        v[pos]=0;
        for(i=h[pos];i!=-1;i=w[i].next)
        {
            pos1=w[i].v;
            if(d[pos1]>d[pos]+w[i].d)
            {
                d[pos1]=d[pos]+w[i].d;
                if(v[pos1]==0)
                {
                    v[pos1]=1;
                    num[pos1]++;
                    if(num[pos1]>n)
                    {
                        return 0;
                    }
                    q[top]=pos1;
                    top++;
                }
            }
        }
        f++;
    }
    return 1;
}
int main()
{
    int n,m,i,si,ni,v,w;
    char op[3];
    scanf("%d",&n);
    while(n!=0)
    {
        numw=0;
        memset(h,-1,sizeof(h));
        n=n+2;
        scanf("%d",&m);
        for(i=1;m>=i;i++)
        {
            scanf("%d %d %s %d",&si,&ni,op,&w);
            if(strcmp(op,"gt")==0)
            {
                insert(si+ni+1,si,-w-1);
            }
            else
            {
                insert(si,si+ni+1,w-1);
            }
        }
        for(i=1;n>i;i++)
        {
            insert(0,i,0);
        }
        if(spfa(n)==1)
        {
            printf("lamentable kingdom\n");
        }
        else
        {
            printf("successful conspiracy\n");
        }
        scanf("%d",&n);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值