HZAU 1205 Sequence Number

题目链接:http://acm.hzau.edu.cn/5th.pdf

G. Sequence Number

In Linear algebra, we have learned the definition of inversion number:

Assuming A is a ordered set with n numbers ( n > 1 ) which are different from eachother. If exist positive integers i , j, ( 1 ≤ i < j ≤ n and A[i] > A[j]),isregarded as one of A’s inversions. The number of inversions is regarded as inversionnumber. Such as, inversions of array <2,3,8,6,1> are <2,1>, <3,1>, <8,1>, <8,6>,<6,1>,and the inversion number is 5.Similarly, we define a new notion —— sequence number, If exist positive integers i, j, ( 1≤ i ≤ j ≤ n and A[i] <= A[j],is regarded as one of A’s sequence pair. Thenumber of sequence pairs is regarded as sequence number. Define j – i as the length of thesequence pair.

Now, we wonder that the largest length S of all sequence pairs for a given array A.

Input

There are multiply test cases.In each case, the first line is a number N(1<=N<=50000 ), indicates the size of the array,the 2th ~n+1th line are one number per line, indicates the element Ai (1<=Ai<=10^9) ofthe array.

Output

Output the answer S in one line for each case.

Sample Input

5

2 3 8 6 1

Sample Output

3

提示

题意:

给出一个数列,求出前面的数小于等于后面的数的若干个数对中相距最长那个的距离,

如样例所示:

符合条件的有(2,3)(2,8)(2,6)(3,8)(3,6),它们本身就不列出来了。

距离最长的是(2,6)数对,长度为3

思路:

我的是单调栈(递减)做法,如果当前元素小于栈顶元素入栈,否则依次和栈中元素计算相对距离且取最长的那一个。

这题对于大部分人应该不算难,反正是难倒我了(⊙﹏⊙)b。

示例程序

#include <cstdio>
#include <algorithm>
using namespace std;
struct jj
{
    int pos,x;
}a[50000];
int main()
{
    int n,i,i1,x,top,maxnum;
    while(scanf("%d",&n)!=EOF)
    {
        top=0;
        maxnum=0;
        for(i=0;n>i;i++)
        {
            scanf("%d",&x);
            if(top==0||a[top-1].x>x)
            {
                a[top].x=x;
                a[top].pos=i;
                top++;
            }
            else
            {
                for(i1=top-1;i1>=0&&a[i1].x<=x;i1--)
                {
                    maxnum=max(maxnum,i-a[i1].pos);
                }
            }
        }
        printf("%d\n",maxnum);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值