HZAU 1199 Little Red Riding Hood

1199: Little Red Riding Hood

Time Limit: 1 Sec   Memory Limit: 1280 MB
Submit: 892   Solved: 144
[ Submit][ Status][ Web Board]

Description

    Once upon a time, there was a little girl. Her name was Little Red Riding Hood. One day, her grandma was ill. Little Red Riding Hood went to visit her. On the way, she met a big wolf. “That's a good idea.”,the big wolf thought. And he said to the Little Red Riding Hood, “Little Red Riding Hood, the flowers are so beautiful. Why not pick some to your grandma?” “Why didn't I think of that? Thank you.” Little Red Riding Hood said.

    Then Little Red Riding Hood went to the grove to pick flowers. There were n flowers, each flower had a beauty degree a[i]. These flowers arrayed one by one in a row. The magic was that after Little Red Riding Hood pick a flower, the flowers which were exactly or less than d distances to it are quickly wither and fall, in other words, the beauty degrees of those flowers changed to zero. Little Red Riding Hood was very smart, and soon she took the most beautiful flowers to her grandma’s house, although she didn’t know the big wolf was waiting for her. Do you know the sum of beauty degrees of those flowers which Little Red Riding Hood pick? 

Input

    The first line input a positive integer T (1≤T≤100), indicates the number of test cases. Next, each test case occupies two lines. The first line of them input two positive integer n and

k (2 <= n <= 10^5 ) ,1 <=  k <= n ), the second line of them input n positive integers a (1<=a <=10^5)

Output

    Each group of outputs occupies one line and there are one number indicates the sum of the largest beauty degrees of flowers Little Red Riding Hood can pick. 

Sample Input

1 
3 1 
2 1 3

Sample Output

5

HINT

官方题解:


Source

示例程序

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int main()
{
    int t,n,k,i,dp[100001],a[100001];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d",&n,&k);
        memset(dp,0,sizeof(dp));
        for(i=1;n>=i;i++)
        {
            scanf("%d",&a[i]);
        }
        dp[1]=a[1];
        for(i=2;k+1>=i;i++)
        {
            dp[i]=max(a[i],dp[i-1]);
        }
        for(i=k+2;n>=i;i++)
        {
            dp[i]=max(dp[i-1],dp[i-k-1]+a[i]);
        }
        printf("%d\n",dp[n]);
    }
    return 0;
}
 
/**************************************************************
    Problem: 1199
    Code Length: 668 B
    Language: C++
    Result: Accepted
    Time:252 ms
    Memory:1744 kb
****************************************************************/

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值