华中农业大学第五届程序设计大赛 A Little Red Riding Hood [BIT优化dp]【动态规划】

题目链接:http://acm.hzau.edu.cn/problem.php?id=1199

——————————————————————————————————————————
1199: Little Red Riding Hood
Time Limit: 1 Sec Memory Limit: 1280 MB
Submit: 937 Solved: 166
[Submit][Status][Web Board]
Description
Once upon a time, there was a little girl. Her name was Little Red Riding Hood. One day, her grandma was ill. Little Red Riding Hood went to visit her. On the way, she met a big wolf. “That’s a good idea.”,the big wolf thought. And he said to the Little Red Riding Hood, “Little Red Riding Hood, the flowers are so beautiful. Why not pick some to your grandma?” “Why didn’t I think of that? Thank you.” Little Red Riding Hood said.

Then Little Red Riding Hood went to the grove to pick flowers. There were n flowers, each flower had a beauty degree a[i]. These flowers arrayed one by one in a row. The magic was that after Little Red Riding Hood pick a flower, the flowers which were exactly or less than d distances to it are quickly wither and fall, in other words, the beauty degrees of those flowers changed to zero. Little Red Riding Hood was very smart, and soon she took the most beautiful flowers to her grandma’s house, although she didn’t know the big wolf was waiting for her. Do you know the sum of beauty degrees of those flowers which Little Red Riding Hood pick?

Input
The first line input a positive integer T (1≤T≤100), indicates the number of test cases. Next, each test case occupies two lines. The first line of them input two positive integer n and

k (2 <= n <= 10^5 ) ,1 <= k <= n ), the second line of them input n positive integers a (1<=a <=10^5)

Output
Each group of outputs occupies one line and there are one number indicates the sum of the largest beauty degrees of flowers Little Red Riding Hood can pick.

Sample Input
1
3 1
2 1 3
Sample Output
5

———————————————————————————————————————————
题目大意:
就是一个序列,拿取的最大价值,拿取一个后,半径为k的位置价值都变为0了。

解题思路:

很明显更的dp

设dp[i]为到拿取第i个位置的最大价值,

转移就是

dp[i]=a[i]+max{dp[j]  j<ik}

由于最大值是前缀最大值,所以用一个树状数组维护就好了

附本题代码
———————————————————————————————————————————

#include <bits/stdc++.h>
typedef long long int LL;
using namespace std;

const int N   = 2e5+7;
//const int INF = (~(1<<31));

int read(){
    int x=0,f=1;char ch = getchar();
    while(ch<'0'||ch>'9') ch = getchar();
    while('0'<=ch&&ch<='9'){x=(x<<3)+(x<<1)+ch-'0';ch = getchar();}
    return x;
}
/*******************************************/

int a[N];
int n,k;

LL mx[N];
#define lowbit(x) (x&-x)
void update(int i,LL v){
    for(;i<=n;i+=lowbit(i)) mx[i]=max(mx[i],v);
}

LL getMax(int i){
    if(i<=0) return 0;
    LL ans = 0;
    for(;i;i-=lowbit(i)) ans = max(ans,mx[i]);
    return ans;
}

int main(){//printf("%d\n",INF);
    int _;
    scanf("%d",&_);
    while(_--){memset(mx,0,sizeof(mx));
        scanf("%d%d",&n,&k);
        for(int i=1;i<=n;i++)    a[i]=read();

        LL ans = 0,tmp;
        for(int i=1;i<=n;i++){
            tmp=a[i]+getMax(i-k-1);
            update(i,tmp);
            ans = max(ans,tmp);
        }
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值