SDUT 2136 数据结构实验之二叉树的建立与遍历

数据结构实验之二叉树的建立与遍历

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
       已知一个按先序序列输入的字符序列,如abc,,de,g,,f,,,(其中逗号表示空节点)。请建立二叉树并按中序和后序方式遍历二叉树,最后求出叶子节点个数和二叉树深度。

Input
 输入一个长度小于50个字符的字符串。
Output
输出共有4行:
第1行输出中序遍历序列;
第2行输出后序遍历序列;
第3行输出叶子节点个数;
第4行输出二叉树深度。
Example Input
abc,,de,g,,f,,,
Example Output
cbegdfacgefdba35
Hint
#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
typedef struct BTnode
{
    char data;
    struct BTnode *l;
    struct BTnode *r;
}BTnode;
char bt[55];
int cnt;
BTnode *Create()
{
    BTnode *root;
    if(bt[++cnt]==',')
        root=NULL;
    else
    {
        root=(BTnode *)malloc(sizeof(BTnode));
        root->data=bt[cnt];//if判断的时候cnt已经++!!
        root->l=Create();
        root->r=Create();
    }
    return root;
}
void Inorder(BTnode *root)
{
    if(root!=NULL)
    {
        Inorder(root->l);
        printf("%c",root->data);
        Inorder(root->r);
    }
}
void Postorder(BTnode *root)
{
    if(root!=NULL)
    {
        Postorder(root->l);
        Postorder(root->r);
        printf("%c",root->data);
    }
}
int Getleaf(BTnode *root)
{
    if(root==NULL)
        return 0;
    if(root->l==NULL&&root->r==NULL)
        return 1;
    return Getleaf(root->l)+Getleaf(root->r);
}
int Gethigh(BTnode *root)
{
    int n,m;
    if(root==NULL)
        return 0;
    else//遍历左子树和右子树找出左右子树最大深度
    {
        n=Gethigh(root->l);
       // printf("*%d\n",n);
        m=Gethigh(root->r);
        //printf("**%d\n",m);
        if(n>m)
            return n+1;
        else
            return m+1;
    }
}
int main()
{
    while(scanf("%s",bt)!=EOF)
    {
        int h=0,leaf=0;
        cnt=-1;//因为是++cnt,所以要从-1开始
        BTnode *root;
        root=Create();
        Inorder(root);
        printf("\n");
        Postorder(root);
        printf("\n");
        leaf=Getleaf(root);
        h=Gethigh(root);
        printf("%d\n%d\n",leaf,h);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值