Six Degrees of Cowvin Bacon (最短路)

59 篇文章 0 订阅
5 篇文章 0 订阅
The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon". 
The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one 'degree' away from the other. If a two cows have never worked together but have both worked with a third cow, they are considered to be two 'degrees' away from each other (counted as: one degree to the cow they've worked with and one more to the other cow). This scales to the general case. 

The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship path exists between every pair of cows. 


Input
* Line 1: Two space-separated integers: N and M 
* Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers tell which cows were. 
Output

* Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows. 


Sample Input
4 2
3 1 2 3
2 3 4
Sample Output

100


Hint

[Cow 3 has worked with all the other cows and thus has degrees of separation: 1, 1, and 1 -- a mean of 1.00 .] 

思路:最短路问题。

在建图的时候要注意将对角线一列设为0,其余在初始状态下设为INF无穷大

然后将在一个集合的元素之间的距离设为1(这里的图为对称矩阵!!)

之后再用Floyd算法更新间接有关系的坐标Map[i][j]=min(Map[i][j],Map[i][k]+Map[k][j]);

最后输出Min*100/(n-1)(这里注意,一定要先乘100,再去取平均,int的数不能整除的话会舍去小数点后面的数,导致结果扩大100倍后误差较大!!!)

#include<cstdio>
#include<cstring>
#include<algorithm>
#define INF 99999999
using namespace std;
int main()
{
    int n,m,t,a[305];
    int Map[305][305];
    scanf("%d %d",&n,&m);
    for(int i=0;i<=n;i++)
    {
        Map[i][i]=0;
        for(int j=i+1;j<=n;j++)
                Map[i][j]=Map[j][i]=INF;
    }
    for(int i=1;i<=m;i++)
    {
        scanf("%d",&t);
        for(int j=1;j<=t;j++)
            scanf("%d",&a[j]);
        for(int x=1;x<=t;x++)
            for(int y=x+1;y<=t;y++)
                Map[a[x]][a[y]]=Map[a[y]][a[x]]=1;
    }
    for(int k=1;k<=n;k++)//Floyd算法
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                Map[i][j]=min(Map[i][j],
                              Map[i][k]+Map[k][j]);
            }
        }
    }
    /*for(int i=1;i<=n;i++){
        for(int j=1;j<=n;j++)
        printf("%10d",Map[i][j]);
        printf("\n");
    }*/
    int Min=INF,temp;
    for(int i=1;i<=n;i++)
    {
        temp=0;
        for(int j=1;j<=n;j++)
            temp+=Map[i][j];
        if(temp<Min)
            Min=temp;
    }
    printf("%d\n",Min*100/(n-1));//重要点,先乘后除,防止误差过大
    return 0;
}


  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值