Apple Catching

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds. 


Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples).

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.
Input
* Line 1: Two space separated integers: T and W

* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.
Output
* Line 1: The maximum number of apples Bessie can catch without walking more than W times.
Sample Input
7 2
2
1
1
2
2
1
1
Sample Output
6
Hint
INPUT DETAILS:

Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice.

OUTPUT DETAILS: 

Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.      

题意:一奶牛站在树下,有两棵树,每分钟都会有一棵树落下一个苹果。牛可以再T时间内在树下移动W次,问牛最多可在树下得到多少个苹果。
思路:三维数组存储每个状态下的苹果数目,dp[i][j][0/1] 时间 步数 树编号
两棵树,记作0号树和1号树。

从不移动,即移动0次状态开始动规计算。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[1001][31][2];//时间 步数 树编号
int main()
{
    int n,w;
    scanf("%d %d",&n,&w);
    int a[n+1];
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&a[i]);
        a[i]--;
    }
    memset(dp,0,sizeof(dp));
    for(int i=1;i<=n;i++)
    {
        dp[i][0][a[i]]=dp[i-1][0][a[i]]+1;//在不移动的情况下进行计算
        dp[i][0][!a[i]]=dp[i-1][0][!a[i]];//不移动,另外一棵树的情况
        for(int j=1;j<=w;j++)
            dp[i][j][a[i]]=max(dp[i-1][j-1][!a[i]],dp[i-1][j][a[i]])+1,//移动一步,对当下的树下的苹果个数进行处理
            dp[i][j][!a[i]]=dp[i-1][j][!a[i]];//对另外一棵树下的苹果进行处理
    }
    int Max=0;
    for(int i=0;i<=w;i++)
        Max=max(Max,max(dp[n][i][0],dp[n][i][1]));
    printf("%d\n",Max);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值