Apple Catching【DP】

7 篇文章 0 订阅

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds. 

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples). 

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.

Input

* Line 1: Two space separated integers: T and W 

* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.

Output

* Line 1: The maximum number of apples Bessie can catch without walking more than W times.

Sample Input

7 2
2
1
1
2
2
1
1

Sample Output

6

Hint

INPUT DETAILS: 

Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice. 

OUTPUT DETAILS: 

Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.

 

题意:有两棵苹果树,在每一分钟这两棵树中只有一棵会掉落1个苹果,一个人可以在这T分钟内在两棵树之间最多来回W次,问在T分钟之内可以得到最大的苹果数量。

思路:用动态规划思想,第i分钟第j次移动后的苹果数量,等于前一分钟移动j次和前一分钟不移动中较大的一个。

#include<iostream>
using namespace std;
int dp[10000][50];
int a[1001];

int main()
{
    int T,W;
    cin>>T>>W;
    for(int i=1; i<=T; i++)
        cin>>a[i];
    if(a[1]==1)//初始化第一个苹果下路位置
    {
        dp[1][0]=1;
        dp[1][1]=0;
    }
    else
    {
        dp[1][1]=1;
        dp[1][0]=0;
    }
    for(int i=2; i<=T; i++)
        for(int j=0; j<=W; j++)
        {
            dp[i][j]=max(dp[i-1][j],dp[i-1][j-1]);
            if(a[i]==j%2+1)//如果人刚好在下落苹果的位置,数量加一。
                dp[i][j]++;
        }
    int res=-1;
    for(int i=0; i<=W; i++)//找最大值
        if(res<dp[T][i])
            res=dp[T][i];
    cout<<res<<endl;
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值