Wooden Sticks

27 篇文章 0 订阅
14 篇文章 0 订阅
题目连接:https://cn.vjudge.net/contest/202335#problem/I
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 
(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup. 
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) . 
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces. 
Output
The output should contain the minimum setup time in minutes, one per line. 
Sample Input


4 9 5 2 2 1 3 5 1 4 

2 2 1 1 2 2 

1 3 2 2 3 1 
Sample Output
2
1

3

题意:输入的数据中,个位一组,一个代表长度,一个代表重量,给出一种安排,使得每个集合里长度相比和质量相比都是降序,且最终的安排使集合数目最少。

思路:该题用贪心来做比较简单。

按照长度按照降序排序,如果相等,则使重量降序排列,处理的时候仅参考重量来处理即可,符合条件的且处理完的量做上标记,不再重复判断。

对于重量的处理上要注意,每次循环判断后要改变成当前符合条件状态下的质量。

另外要注意的是时间的计算放在数据处理时,来考虑。所以代码中时间的增量cnt++的位置很重要!!

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
    int L,W;
}N[5001];
int flag[5001];
int cmp(node a,node b)
{
    if(a.L!=b.L)
        return a.L>b.L;
    else
        return a.W>b.W;
}
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%d %d",&N[i].L,&N[i].W);
        sort(N,N+n,cmp);
        memset(flag,0,sizeof(flag));
        int cnt=0;
        int Min=0;
        for(int i=0;i<n;i++)
        {
            if(flag[i])
                continue;
            Min=N[i].W;
            for(int j=i+1;j<n;j++)
            {
                if(N[j].W<=Min&&!flag[j])
                {
                    flag[j]=1;
                    Min=N[j].W;
                }
            }
            cnt++;//第一个木棒设置时间为1分钟(时间的计算放在木棒处理时考虑解题)
        }
        printf("%d\n",cnt);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值