Wireless Network

59 篇文章 0 订阅
4 篇文章 0 订阅
An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 


In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 


The input will not exceed 300000 lines. 
Output
For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output
FAIL
SUCCESS
思路:简单并查集

这里要注意,在判断是否连通时要考虑到两台机器是否都完全修好,代码中期初输入S时,没有判断两台机器是否完全修好,造成代码在finds函数里无限循环,提交错误!!

#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
int father[1005];
struct node
{
    double x,y;
}f[1005];
int finds(int i)
{
    while(i!=father[i])
        i=father[i];
    return i;
}
void merges(int a,int b)
{
    int fa=finds(a);
    int fb=finds(b);
    if(fa!=fb)
        father[fb]=fa;
}
double dist(node a,node b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)
                +(a.y-b.y)*(a.y-b.y));
}
int main()
{
    int n;
    double d;
    char ch;
    scanf("%d %lf",&n,&d);
    for(int i=1;i<=n;i++)
        scanf("%lf %lf",&f[i].x,&f[i].y);
    memset(father,-1,sizeof(father));
    getchar();
    while(scanf("%c",&ch)!=EOF)
    {
        int ai,bi;
        if(ch=='O')
        {
            scanf("%d",&ai);
            father[ai]=ai;
            for(int i=1;i<=n;i++)
            {
                if(father[i]!=-1&&father[ai]!=-1)
                {
                    if(dist(f[i],f[ai])<=d)
                        merges(i,ai);
                }
            }
            /*for(int i=1;i<=n;i++)
            printf("father[%d]=%d\n",i,father[i]);*/
        }
        else if(ch=='S')
        {
            scanf("%d %d",&ai,&bi);
            if(father[ai]!=-1&&father[bi]!=-1){//该重判断很重要!!
                if(finds(ai)==finds(bi))
                    printf("SUCCESS\n");
                else
                    printf("FAIL\n");
            }
            else printf("FAIL\n");
        }
        getchar();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值