UPC 问题 L: Shift only

问题 L: Shift only
时间限制: 1 Sec 内存限制: 128 MB
提交: 286 解决: 223
[提交] [状态] [讨论版] [命题人:admin]
题目描述

There are N positive integers written on a blackboard: A1,…,AN.
Snuke can perform the following operation when all integers on the blackboard are even:
Replace each integer X on the blackboard by X divided by 2.
Find the maximum possible number of operations that Snuke can perform.

Constraints
1≤N≤200
1≤Ai≤109

输入

Input is given from Standard Input in the following format:
N
A1 A2 … AN

输出

Print the maximum possible number of operations that Snuke can perform.

样例输入

3
8 12 40

样例输出

2

#include<bits/stdc++.h>
using namespace std;
int del(int a[],int n,int flag)
{
    for(int i=0;i<n;i++){
        a[i]=a[i]/2;
        if(a[i]%2!=0)
            flag=0;
    }
    return flag;
}
int main()
{
    int n;cin>>n;
    int num[n];
    int flag=1;
    int cnt=0;
    for(int i=0;i<n;i++)
    {
        cin>>num[i];
        if(num[i]%2!=0)
            flag=0;
    }
    if(flag==0)
        cout<<"0"<<endl;
    else
    {
        while(flag==1){
            flag=del(num,n,flag);
            cnt++;
        }
        cout<<cnt<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值