Shift only

题目描述

There are N positive integers written on a blackboard: A1,…,AN.
Snuke can perform the following operation when all integers on the blackboard are even:
Replace each integer X on the blackboard by X divided by 2.
Find the maximum possible number of operations that Snuke can perform.

Constraints
1≤N≤200
1≤Ai≤109

 

输入

Input is given from Standard Input in the following format:
N
A1 A2 ... AN

 

输出

Print the maximum possible number of operations that Snuke can perform.

 

样例输入

3
8 12 40

 

样例输出

2

 

提示

Initially, [8,12,40] are written on the blackboard. Since all those integers are even, Snuke can perform the operation.
After the operation is performed once, [4,6,20] are written on the blackboard. Since all those integers are again even, he can perform the operation.
After the operation is performed twice, [2,3,10] are written on the blackboard. Now, there is an odd number 3 on the blackboard, so he cannot perform the operation any more.
Thus, Snuke can perform the operation at most twice.

题目描述
黑板上有N个正整数A1…AN。
当黑板上的所有整数都是偶数时,Snuke可以执行以下操作:
将黑板上的每个整数X替换为X / 2。
查找Snuke可以执行的操作的最大可能数量。
约束
1≤N≤200
1≤Ai≤109
输入
输入来自以下格式的标准输入:
N
A1 A2……一个
输出
打印Snuke可以执行的最大操作数。
样例输入
3
8 12 40
样例输出
2

#include <iostream>
#define inf 0x3f3f3f
using namespace std;
int a[210],n;
int panduan()
{
    int i;
    for(i=0;i<n;i++)
    {
        if(a[i]%2!=0)
            return 0;
    }
    return 1;
}
int main()
{
    int c=0;
    int i,j;
    cin>>n;
    for(i=0;i<n;i++)
        cin>>a[i];
    while(panduan()==1)
    {
        c++;
        for(i=0;i<n;i++)
            a[i]/=2;
    }
    cout<<c<<endl;
    return 0;
}
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值