概率

Description

As Harry Potter series is over, Harry has no job. Since he wants to make quick money, (he wants everything quick!) so he decided to rob banks. He wants to make a calculated risk, and grab as much money as possible. But his friends - Hermione and Ron have decided upon a tolerable probability P of getting caught. They feel that he is safe enough if the banks he robs together give a probability less thanP.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a real number P, the probability Harry needs to be below, and an integerN (0 < N ≤ 100), the number of banks he has plans for. Then followN lines, where line j gives an integer Mj (0 < Mj ≤ 100) and a real number Pj . Bankj contains Mj millions, and the probability of getting caught from robbing it isPj. A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Output

For each case, print the case number and the maximum number of millions he can expect to get while the probability of getting caught is less thanP.

Sample Input

3

0.04 3

1 0.02

2 0.03

3 0.05

0.06 3

2 0.03

2 0.03

3 0.05

0.10 3

1 0.03

2 0.02

3 0.05

Sample Output

Case 1: 2

Case 2: 4

Case 3: 6


题意:
输入一个数,表示一共有多少组数据,输入一个浮点型数据表示哈利波特被抓的几率不超过这个的情况下能头的最多钱,输入一个整型表示银行数,求哈利波特在不被抓的情况下头的最多钱。
思路:
背包;第一次做的时候把概率当做背包(放大100000倍化为整数):在此范围内最多能抢多少钱  ,正确的方程是:dp[j]=max(dp[j],dp[j-m[i]]*(1-p[i])); 其中,dp[j]表示抢j块大洋的最大的逃脱概率(不被抓的概率),始化为:f[0]=1,其余初始化为0  (抢0块大洋肯定不被抓嘛).
代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int m[10000+5];//各家银行里的钱
double  p[10000+5];//被抓的概率
double  dp[10000+5];//抢多少钱不被抓的概率
int main()
{
    int T;
    int N;//N银行数量
    double P;//被抓的概率
    scanf("%d",&T);
    int casex=1;
    while(T--)
    {
        int sum=0;
        scanf("%lf%d",&P,&N);
        for(int i=0;i<N;i++)
        {
          scanf("%d%lf",&m[i],&p[i]);
          sum+=m[i];
        }
        memset(dp,0,sizeof(dp));
        dp[0]=1;//抢0元钱不被抓的概率肯定为1
        for(int i=0;i<N;i++)
            for(int j=sum;j>=m[i];j--)
            dp[j]=max(dp[j],dp[j-m[i]]*(1-p[i]));
            for(int j=sum;j>=0;j--)
            {
                if(dp[j]>=1-P)
                {
                    printf("Case %d: %d\n",casex++,j);
                    break;
                }
            }
    }
    return 0;
}

 
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值