poj3259

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 13908 Accepted: 4889

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

代码时间超长,初学Bellman-Ford 算法,理解不够透彻,以后再来优化了!

#include <iostream>
using namespace std;
#define INF 20000
#define NUM 501
int paths[NUM][NUM];
int dist[NUM];

bool bellman_ford(int size)
{
	int i,j,k;
	bool flag;
	
    for ( i = 2; i <= size; i++ )
		dist[i] = INF;
	dist[1] = 0;
	for ( k = 1; k < size; k++ )
	{
		flag = false;
		for ( i = 1; i <= size; i++ )
		{
			for ( j = 1; j <= size; j++ )
			{
				if ( dist[i] != INF && paths[i][j] != INF && dist[j] > dist[i]+paths[i][j] )
				{
					dist[j] = dist[i]+paths[i][j];
					flag = true;
				}
			}
		}
        if (!flag) break;
	}
	for ( i = 1; i <= size; i++ )
	{
		for ( j = 1; j <= size; j++ )
		{
			if ( dist[i] != INF && paths[i][j] != INF && dist[j] > dist[i]+paths[i][j] )
				return true;
		}
	}
	return false;
}

int main()
{
	int f;
    int n,m,w;
	int s,e,t;
	int i,j;
	
	cin >> f;
	while (f--)
	{
		scanf("%d%d%d",&n,&m,&w);
		
		for ( i = 1; i <= n; i++ )
		{
			for ( j = 1; j <= n ; j++ )
				paths[i][j] = INF;
		}
		for ( i = 1; i <= m; i++ )
		{
			scanf("%d%d%d",&s,&e,&t);
			if ( paths[s][e] > t )
				paths[s][e] = paths[e][s] = t;
		}
		for ( i = 1; i <= w; i++ )
		{
			scanf("%d%d%d",&s,&e,&t);
			paths[s][e] = (-1)*t;
		}
		if (bellman_ford(n))
			cout << "YES" << endl;
		else cout << "NO" << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值