POJ 3259

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1…N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself ? .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2… M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2… M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1… F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES
Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题意:农夫在农场发现有虫洞,虫洞可以穿越时空回到过去,虫洞由3个数组成,比如 1 2 3这个虫洞,可以从位置1传送到位置2,花费的时间为 -3s(就是回到3秒前),然后最后让你判断农夫是否可以通过虫洞穿越到某个位置碰到之前的自己

思路:一道判断负环的模板题,用floyd和Bellmand—Ford都可以判断负环。

Bellmand—Ford

#include<stdio.h>
#include<iostream>
#include<math.h>
#include<algorithm>
#include<string.h>
#include<queue>
using namespace std;
int inf=99999999;
int n,m,w,dis[505],mapp[505][505],u[6000],v[6000],l[6000];
void bf()
{
    for(int a=1;a<=n;a++)
        dis[a]=inf;
    dis[1]=0;
    for(int i=1;i<=n-1;i++)
    {
        int check=0;
        for(int j=1;j<=2*m+w;j++)
        {
            if(dis[v[j]]>dis[u[j]]+l[j])
            {
               dis[v[j]]=dis[u[j]]+l[j];
                check=1;
            }
        }
        if(check==0)break;
    }
        for(int j=1;j<=2*m+w;j++)
        {
            if(dis[v[j]]>dis[u[j]]+l[j])  //在上一步的优化中,dis[v[j]]已经最小,此时如果还能继续变小的话就说明存在负环
            {
                printf("YES\n");return;
            }
        }
    printf("NO\n");
    return ;
}
int main()
{
    int f;
    scanf("%d",&f);
    while(f--)
    {
        scanf("%d%d%d",&n,&m,&w);
        for(int a=1;a<=2*m;a+=2)
        {
            scanf("%d%d%d",&u[a],&v[a],&l[a]);
            u[a+1]=v[a],v[a+1]=u[a],l[a+1]=l[a]; //注意路是双向的
        }
        for(int a=2*m+1;a<=w+2*m;a++)
        {
            scanf("%d%d%d",&u[a],&v[a],&l[a]);
            l[a]=-l[a];
        }
        bf();
    }
    return 0;
}

floyd

#include<stdio.h>
#include<iostream>
#include<math.h>
#include<algorithm>
#include<string.h>
#include<queue>
using namespace std;
int inf=99999999;
int n,m,w,mapp[505][505];
int  floyd()
{
    for(int k=1;k<=n;k++)
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(mapp[i][j]>mapp[i][k]+mapp[k][j])
                    mapp[i][j]=mapp[i][k]+mapp[k][j];
            }
            if(mapp[i][i]<0) //最初到自己的时间是0,如果存在负环的话到自己的最小时间就会变成一个负数,能循环回来,那就说明存在负环
                    return 1;
        }
    }
    return 0;
}
int main()
{
    int f;
    scanf("%d",&f);
    while(f--)
    {
        scanf("%d%d%d",&n,&m,&w);
        int u,v,g;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                 if(i==j)
                    mapp[i][j]=0;
                 else
                    mapp[i][j]=inf;
            }
        }
        for(int a=1;a<=m;a++)
        {
            scanf("%d%d%d",&u,&v,&g);
            if(mapp[u][v]>g)
                mapp[u][v]=mapp[v][u]=g;
        }
        for(int a=1;a<=w;a++)
        {
            scanf("%d%d%d",&u,&v,&g);
            mapp[u][v]=-g;
        }
        if(floyd())
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值