A1099. Build A Binary Search Tree (30)

 definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format "left_index right_index", provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:
9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42
Sample Output:
58 25 82 11 38 67 45 73 42
中序遍历二叉树为数据递增,先序遍历为序号递增

#include<cstdio>
#include<queue>
#include<algorithm>
using namespace std;
const int maxn = 101;
bool vis[maxn] = {0};
int num[maxn],n;
struct Node{
	int data;
	int lchild,rchild;		
}node[maxn];
int number = 0;
void inOrder(int root){
	if(root==-1) return;
	inOrder(node[root].lchild);
	node[root].data = num[number++];
	inOrder(node[root].rchild);
}
int sq = 0;
void BFS(int v){
	queue<int> q;
	q.push(v);
	vis[v] = 1;
	printf("%d",node[v].data);
	if(sq<n-1) printf(" ");
	sq++;
	while(!q.empty()){
		int t = q.front();
		q.pop();
		int l = node[t].lchild,r = node[t].rchild;
		if(l!=-1){
			printf("%d",node[l].data);
			if(sq<n-1) putchar(' ');
			else putchar('\n');
			q.push(l);
			sq++;
		}
		if(r!=-1){
			printf("%d",node[r].data);
			if(sq<n-1) putchar(' ');
			else putchar('\n');
			q.push(r);
			sq++;
		}
	}
}
int main(){
	scanf("%d",&n);
	for(int i = 0;i < n;i++){
		scanf("%d %d",&node[i].lchild,&node[i].rchild);
	}
	for(int i = 0;i < n;i++)
		scanf("%d",&num[i]);
	sort(num,num+n);		//排序,中序
	inOrder(0);
	BFS(0);
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值