HDOJ 2818 Building Block

Building Block

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4222    Accepted Submission(s): 1316


Problem Description
John are playing with blocks. There are N blocks (1 <= N <= 30000) numbered 1...N。Initially, there are N piles, and each pile contains one block. Then John do some operations P times (1 <= P <= 1000000). There are two kinds of operation:

M X Y : Put the whole pile containing block X up to the pile containing Y. If X and Y are in the same pile, just ignore this command. 
C X : Count the number of blocks under block X 

You are request to find out the output for each C operation.
 

Input
The first line contains integer P. Then P lines follow, each of which contain an operation describe above.
 

Output
Output the count for each C operations in one line.
 

Sample Input
  
  
6 M 1 6 C 1 M 2 4 M 2 6 C 3 C 4
 

Sample Output
  
  
1 0 2
 
#include <cstdio>
#include <cstring>
using namespace std;

int father[30005];
int rank[30005];
int maxNum[30005];

int find(int x){
    if (father[x] != x){
        int fa = father[x];
        father[x] = find(fa);
        rank[x] += rank[fa];
    }
    return father[x];
}

void Union(int x, int y){
    int fx = find(x);
    int fy = find(y);
    if (fx != fy){
        father[fx] = fy;
        rank[fx] += maxNum[fy] + 1;
        maxNum[fy] += maxNum[fx] + 1;
    }
}

int main(){
    int t;
    int x, y, i;
    char c;
    while (scanf("%d%*c", &t) != EOF){
        memset(rank, 0, sizeof(rank));
        memset(maxNum, 0, sizeof(maxNum));

        for (i = 0; i <= 30005; i++)
            father[i] = i;
        while (t--){
            c = getchar();
            if (c == 'M'){
                scanf("%d%d%*c", &x, &y);
                Union(x, y);
            }
            else{
                scanf("%d%*c", &x);
                find(x);
                printf("%d\n", rank[x]);
            }
        }
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值